Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30493 - KDE systemsettings - Impossible to change settings

Attached to Project: Arch Linux
Opened by Flavio Lopes (vovotux) - Saturday, 30 June 2012, 14:45 GMT
Last edited by Andrea Scarpino (BaSh) - Saturday, 30 June 2012, 15:54 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Impossible to change settings that needed the root privilegies in KDE systemsettings. Clicking the Apply button nothing happens but clicking the back or close button a dialog box appears prompting for apply the changes. Clicking the new Apply button a new dialog box shows the message: 'Unable to authenticate/execute the action: (code 3)'
Running KDE systemsettings from 'kdesu systemsettings' or 'kdesu kcmshell4 kdm' the same error occurs.

Additional info: Kdesu works no problem. Dbus is started from rc.conf before kdm. Arch clean install on june 27.
* package version(s) KDE 4.8.4
* config and/or log files etc.
[vovo@myhost ~]$ sudo cat /var/log/* |grep polkit
Jun 28 21:43:17 localhost sudo: vovo : TTY=pts/1 ; PWD=/home/vovo ; USER=root ; COMMAND=/usr/bin/pacman -S polkit-kde polkit-qt
cat: /var/log/ConsoleKit: É um diretório
cat: /var/log/cups: É um diretório
Jun 28 21:11:44 localhost console-kit-daemon[535]: WARNING: polkit_authority_get: Error getting authority: Error initializing authority: Could not connect: No such file or directory
Jun 28 21:44:35 localhost console-kit-daemon[531]: WARNING: polkit_authority_get: Error getting authority: Error initializing authority: Could not connect: No such file or directory
Jun 29 08:41:26 localhost console-kit-daemon[526]: WARNING: polkit_authority_get: Error getting authority: Error initializing authority: Could not connect: No such file or directory
Jun 30 10:42:07 localhost console-kit-daemon[542]: WARNING: polkit_authority_get: Error getting authority: Error initializing authority: Could not connect: No such file or directory
Jun 28 21:11:44 localhost console-kit-daemon[535]: WARNING: polkit_authority_get: Error getting authority: Error initializing authority: Could not connect: No such file or directory
Jun 28 21:44:35 localhost console-kit-daemon[531]: WARNING: polkit_authority_get: Error getting authority: Error initializing authority: Could not connect: No such file or directory
Jun 29 08:41:26 localhost console-kit-daemon[526]: WARNING: polkit_authority_get: Error getting authority: Error initializing authority: Could not connect: No such file or directory
Jun 30 10:42:07 localhost console-kit-daemon[542]: WARNING: polkit_authority_get: Error getting authority: Error initializing authority: Could not connect: No such file or directory
Jun 28 21:11:44 localhost console-kit-daemon[535]: WARNING: polkit_authority_get: Error getting authority: Error initializing authority: Could not connect: No such file or directory
Jun 28 21:44:35 localhost console-kit-daemon[531]: WARNING: polkit_authority_get: Error getting authority: Error initializing authority: Could not connect: No such file or directory
Jun 29 08:41:26 localhost console-kit-daemon[526]: WARNING: polkit_authority_get: Error getting authority: Error initializing authority: Could not connect: No such file or directory
cat: /var/log/old: É um diretório
Jun 30 10:42:07 localhost console-kit-daemon[542]: WARNING: polkit_authority_get: Error getting authority: Error initializing authority: Could not connect: No such file or directory
cat: /var/log/speech-dispatcher: É um diretório
[2012-06-28 20:44] installed polkit (0.105-1)
[2012-06-28 20:44] installed polkit-qt (0.103.0-1)
[2012-06-28 20:44] installed polkit-kde (0.99.0-2)
[2012-06-28 21:43] Running 'pacman -S polkit-kde polkit-qt'
[2012-06-28 21:43] upgraded polkit-kde (0.99.0-2 -> 0.99.0-2)
[2012-06-28 21:43] upgraded polkit-qt (0.103.0-1 -> 0.103.0-1)

Steps to reproduce:
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Saturday, 30 June 2012, 15:54 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#30476 

Loading...