Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30476 - KDM login: cannot open consolekit session: message did not receive a reply timeout by message bus

Attached to Project: Arch Linux
Opened by Cássio Pereira (cpereira) - Thursday, 28 June 2012, 15:36 GMT
Last edited by Ionut Biru (wonder) - Friday, 06 July 2012, 01:27 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

After installing arch-64bit along with kde-meta, I set KDM as the login manager.
I also installed dbus, added it to my daemons section in rc.conf and made sure it's running.

Whenever I login via KDM I get the following message:

"Warning: cannot open consolekit session: unable to open session: message did not receive a reply (timeout by message bus)"

I cannot auto-mount usb sticks and probably everything related to consolekit will also have problems...

The strange thing is that I have a 32-bit install with the same versions of all the software and I do not get this problem. Not sure if it's related to x64...

Additional info:
- 3.4.4-2-ARCH #1 SMP PREEMPT Sun Jun 24 18:59:47 CEST 2012 x86_64 GNU/Linux
- consolekit 0.4.6-4
- dbus 1.6.0-1
- dbus-core 1.6.0-5
- polkit 0.105-1
- polkit-kde 0.99.0-2
- kdebase-workspace 4.8.4-1
- let me know if any additional package/config files information would be helpful.

Steps to reproduce:
1 - install arch 64 bit
2 - install kde-meta
3 - set inittab to boot in level 5 and start kdm
4 - login via kdm
This task depends upon

Closed by  Ionut Biru (wonder)
Friday, 06 July 2012, 01:27 GMT
Reason for closing:  Fixed
Additional comments about closing:  dbus-core 1.6.2-2
Comment by Cássio Pereira (cpereira) - Thursday, 28 June 2012, 15:51 GMT
Ok, talking in the #archlinux channel on freenode, user nabukadnezar43 had a solution to the problem. Running dbus-uuidgen > /etc/machine-id solved the problem. Another user reported that should have happened automatically. I just did a fresh install, so I'm guessing this is a bug, as my /etc/machine-id was not generated. Don't know if the dbus package is supposed to do that once installed. I don't see any relevant info on that on my /var/log/pacman.log and I didn't see it in the beginners guide.
Comment by Mantas Mikulėnas (grawity) - Thursday, 28 June 2012, 16:01 GMT
Normally, /etc/machine-id should have been created by `systemd-machine-id-setup` during installation of the "systemd-tools" package. It seems that this did not work because of a missing dependency on "libsystemd" – this is already fixed in systemd-tools 185-4, which is currently in [testing].

Manually running either `systemd-machine-id-setup` or `dbus-uuidgen > /etc/machine-id`, as nabukadnezar43 suggested, fixes the problem as well.
Comment by Dave Reisner (falconindy) - Thursday, 28 June 2012, 17:03 GMT
This is already fixed in testing. We're not using dbus-uuidgen anymore, since systemd-machine-id-setup is smarter about uuid generation with respect to dbus, and dbus can fall back on /etc/machine-id when /var/lib/dbus/machine-id doesn't exist (as of 1.6.0).
Comment by Andika Edo (phiexz) - Thursday, 28 June 2012, 17:07 GMT
i also have this problem. recently fresh install in x86_64 arch.
but i got error when start kdm:
WARNING: polkit_authority_get: Error getting authority: Error initializing authority: Could not connect: No such file or directory

like this issue, i dont have /etc/machine-id file, so i create it with "systemd-machine-id-setup"
but the problem still exist.

"WARNING: polkit_authority_get: Error getting authority: Error initializing authority: Could not connect: No such file or directory"
Comment by A.C. (zepar) - Saturday, 30 June 2012, 12:47 GMT
i also confirm this on fresh install in x86_64
Comment by Jelle van der Waa (jelly) - Monday, 02 July 2012, 16:58 GMT
Confirming is useless, as you can see the solution is provided by grawity and is fixed in [testing]. So soon the solution will be in [extra] or [core]

Loading...