Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30473 - [git] subtree is not available

Attached to Project: Arch Linux
Opened by Alireza Savand (Alir3z4) - Thursday, 28 June 2012, 12:09 GMT
Last edited by Dan McGee (toofishes) - Monday, 19 May 2014, 03:00 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Dan McGee (toofishes)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 16
Private No

Details

Description:
Since git-subtree merged into main git, and also is in the stable. but it's not available at installed git from extra repo

Additional info:
* package version(s)
git 1.7.11.1-1

* config and/or log files etc.
git: 'subtree' is not a git command. See 'git --help'.


Steps to reproduce:
When i run:
$ git subtree
This task depends upon

Closed by  Dan McGee (toofishes)
Monday, 19 May 2014, 03:00 GMT
Reason for closing:  Fixed
Additional comments about closing:  Thanks silvio for the simple patch.
Comment by Dan McGee (toofishes) - Sunday, 01 July 2012, 18:26 GMT
The subtree Makefile is a disaster when it comes to packaging. I'd rather get some upstream fixes in first; this is taking way longer to incorporate into the PKGBUILD than it should becuase it doesn't respect DESTDIR, gitexecdir, etc.
Comment by Alireza Savand (Alir3z4) - Thursday, 05 July 2012, 13:29 GMT
@toolfishes: I agree.
Comment by Jelle van der Waa (jelly) - Saturday, 28 July 2012, 13:55 GMT
Alizera did you contact upstream to fix it?
Comment by Dan McGee (toofishes) - Saturday, 28 July 2012, 15:23 GMT
http://marc.info/?l=git&m=134116914230460&w=2

However, I got zero response...
Comment by Massimiliano Torromeo (mtorromeo) - Friday, 17 August 2012, 16:54 GMT Comment by Dan McGee (toofishes) - Friday, 25 January 2013, 21:09 GMT
If anyone wants to reach out again upstream to get this fixed, please do, but I'm done waiting on it.
Comment by Michael Trunner (trunneml) - Friday, 02 August 2013, 10:18 GMT
  • Field changed: Percent Complete (100% → 0%)
The PKGBUILD from [0] looks good.
Is it still a problem?

[0] https://github.com/mtorromeo/archlinux-packages/tree/master/git-subtree

Comment by Daniel Oertwig (DanielOertwig) - Monday, 25 November 2013, 00:34 GMT
I'd second this, the linked PKGBUILD seems to work fine. Any chance of getting this into extra/git ?
Comment by Michael Trunner (trunneml) - Wednesday, 11 December 2013, 09:35 GMT
Anything new about this?
Comment by Stefan Tatschner (rumpelsepp) - Monday, 31 March 2014, 07:31 GMT
Anything new about this?
Comment by Massimiliano Torromeo (mtorromeo) - Monday, 31 March 2014, 07:35 GMT
I understand that upstream should fix this but this is so easy to fix in the PKGBUILD that I don't really see why we can't workaround the problem in the meanwhile.
Comment by silvio (silvio) - Friday, 18 April 2014, 08:45 GMT
Hi,

please look to this patch. Its based on mtorromeo's pkgbuild but integrated into your PKGBUILD file.

https://gist.github.com/silvio/11031552


Comment by James Denholm (ChemicalRascal) - Sunday, 18 May 2014, 05:25 GMT
A re-spin of Dan's patch has been merged into upstream, and to my understanding will be in 2.0:

http://thread.gmane.org/gmane.comp.version-control.git/248216/focus=248254
http://article.gmane.org/gmane.comp.version-control.git/248641/match=subtree (CTRL-F "jd/subtree", in "Cooking")

This patch allows subtree to be made with the following:

`make -C contrib/subtree prefix=/usr gitexecdir=/usr/lib/git-core all doc`

And installed with the following:

`make -C contrib/subtree prefix=/usr gitexecdir=/usr/lib/git-core DESTDIR="$pkgdir" install install-doc`

Which, of course, roughly approximates the make calls for git core.

EDIT: My bad, turns out these aren't going to be in 2.0.

Loading...