Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30470 - [java-batik] Why not change java-runtime=6 to java-runtime=7?

Attached to Project: Community Packages
Opened by Techlive Zheng (techlive) - Thursday, 28 June 2012, 07:28 GMT
Last edited by Lukas Fleischer (lfleischer) - Sunday, 30 September 2012, 13:55 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Lukas Fleischer (lfleischer)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

System requirements

Batik requires the following to be already installed in your system:

Java Runtime Environment

A Java 1.3 or above compatible runtime environment must be present. Note that to support the following features a Java 1.4 or above JRE is required:

SVG 1.2 mouse wheel events

***************************************

According to the official installation notes, java-runtime=7 should be okay, why not keep java-runtime=6?

jre7-openjdk seems satisfied java-runtime=6 requirement, but jre in AUR is not.
This task depends upon

Closed by  Lukas Fleischer (lfleischer)
Sunday, 30 September 2012, 13:55 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 1.7-11.
Comment by Jelle van der Waa (jelly) - Thursday, 28 June 2012, 07:47 GMT
Can't make any sense of your bugreport, but I guess java-runtime=6 so that it supports both jre7 and jre6
Comment by Techlive Zheng (techlive) - Thursday, 28 June 2012, 08:00 GMT
No, java-batik set requirement to java-runtime=6, but after I install jre in AUR or jre7-openjdk, it says "missing dependency for java-batik : java-runtime=6", so, why still keep the dependency to java-runtime=6?
Comment by Jelle van der Waa (jelly) - Thursday, 28 June 2012, 10:02 GMT
Installed fop since it deps on this package and it seems to work for me with opendjk6
Comment by Andreas Radke (AndyRTR) - Thursday, 28 June 2012, 13:47 GMT
Any java pkg should depend only on "java-runtime" to let the user the choice which to pick.

Only if it won't work with some jre branch you should hardcode the version that works.
Comment by Lukas Fleischer (lfleischer) - Thursday, 05 July 2012, 22:58 GMT
It didn't build with any newer version when I updated the package -- I mentioned that in the commit message [1].

techlive: Did you actually try removing the version part and recompiling it in a chroot?

[1] https://projects.archlinux.org/svntogit/community.git/commit/trunk?id=476edf8c17e8c9272f940a14173de84574314ec8
Comment by Lukas Fleischer (lfleischer) - Wednesday, 25 July 2012, 22:21 GMT
I just tried again -- java-batik still isn't Java 7-compliant. Check  FS#28705  for details.
Comment by Ondřej Hošek (RavuAlHemio) - Sunday, 02 September 2012, 23:25 GMT
I think now it is; I haven't had any problems building it on jdk7-openjdk here (though I haven't tried it with headless-only).

Loading...