Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30468 - [dbus 1.6] GDM and NM services fails to start

Attached to Project: Arch Linux
Opened by Pyro Devil (PyroDevil) - Thursday, 28 June 2012, 06:31 GMT
Last edited by Dave Reisner (falconindy) - Sunday, 01 July 2012, 13:48 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Dave Reisner (falconindy)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
Since update from dbus 1.4 to 1.6 I, and apparently some others, have problems with the GDM and NetworkManager service.
I'm using systemd as init environment and it fails to start them.

Here is a snipped from my everthing.log containing a failed boot:
http://pastebin.com/L2KY1VMy

And here is the forum message I posted:
https://bbs.archlinux.org/viewtopic.php?id=143985

Additional info:
* package version(s):
core/dbus-core 1.6.0-5
extra/dbus 1.6.0-1
extra/dbus-glib 0.100-1

extra/networkmanager 0.9.4.0-6
extra/gdm 3.4.1-2

Steps to reproduce:
1. Update to newest dbus and dbus-core (1.6)
2. Restart your PC
-> x server starts but screen is black and the mousepointer is a watch.

Switching to the tty1 and logging on works and reveals that the NM service could not be started.

This task depends upon

Closed by  Dave Reisner (falconindy)
Sunday, 01 July 2012, 13:48 GMT
Reason for closing:  Not a bug
Comment by Tobias Powalowski (tpowa) - Thursday, 28 June 2012, 09:30 GMT
Wasn't there a bug report yesterday?
Comment by Ionut Biru (wonder) - Thursday, 28 June 2012, 10:25 GMT
everything works fine here. Are you using systemd instead of initscripts, gnome fallback? more info will be nice
Comment by Pyro Devil (PyroDevil) - Thursday, 28 June 2012, 10:26 GMT
I searched for "dbus" but didn't found anything related to this issue.
Comment by Pyro Devil (PyroDevil) - Thursday, 28 June 2012, 10:28 GMT
Yes, I am using systemd and the normal gnome desktop, so no fallback mode.
What info do you need?
Comment by Ionut Biru (wonder) - Thursday, 28 June 2012, 10:29 GMT
paste the output of pacman -Qii gdm
Comment by Pyro Devil (PyroDevil) - Thursday, 28 June 2012, 10:31 GMT
Here, but this output is while I am using the old dbus:

Name : gdm
Version : 3.4.1-2
URL : http://www.gnome.org
Licenses : GPL
Groups : gnome-extra
Provides : None
Depends On : libcanberra libxklavier gnome-session gnome-settings-daemon
metacity upower accountsservice consolekit xorg-xrdb nss
Optional Deps : gnome-shell: new login interface
fprintd: fingerprint authentication
Required By : None
Conflicts With : None
Replaces : None
Installed Size : 6820.00 KiB
Packager : Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
Architecture : x86_64
Build Date : Wed Apr 18 01:11:56 2012
Install Date : Wed Apr 18 20:39:30 2012
Install Reason : Explicitly installed
Install Script : Yes
Description : Gnome Display Manager (a reimplementation of xdm)
Backup Files:
UNMODIFIED /etc/pam.d/gdm-autologin
UNMODIFIED /etc/pam.d/gdm-fingerprint
UNMODIFIED /etc/pam.d/gdm
UNMODIFIED /etc/pam.d/gdm-password
UNMODIFIED /etc/pam.d/gdm-smartcard
UNMODIFIED /etc/pam.d/gdm-welcome
MODIFIED /etc/gdm/custom.conf
Comment by Pyro Devil (PyroDevil) - Thursday, 28 June 2012, 10:55 GMT
From my log I think that there is something fishy with the dbus services.

Some parts of the log (If that posted is tldr):

Jun 25 10:53:20 Primat gdm-welcome][564]: AccountsService-WARNING: Failed to connect to the D-Bus daemon: Verbindung ist gescheitert:Verbindungsaufbau abgelehnt
---
Jun 25 10:53:34 Primat dbus[520]: [system] Activating systemd to hand-off: service name='org.freedesktop.ConsoleKit' unit='console-kit-daemon.service'
Jun 25 10:53:59 Primat dbus[520]: [system] Failed to activate service 'org.freedesktop.ConsoleKit': timed out
Jun 25 10:53:59 Primat dbus[520]: [system] Failed to activate service 'org.freedesktop.systemd1': timed out
Jun 25 10:53:59 Primat NetworkManager[505]: <warn> disconnected by the system bus.
Jun 25 10:53:59 Primat dbus[571]: [system] Activating systemd to hand-off: service name='org.freedesktop.login1' unit='dbus-org.freedesktop.login1.service'
Jun 25 10:54:03 Primat NetworkManager[505]: <info> reconnected to the system bus.
Jun 25 10:54:03 Primat dbus[571]: [system] Activating systemd to hand-off: service name='org.bluez' unit='dbus-org.bluez.service'
---
Jun 25 10:54:24 Primat dbus[571]: [system] Failed to activate service 'org.freedesktop.login1': timed out
Jun 25 10:54:24 Primat dbus[571]: [system] Failed to activate service 'org.freedesktop.systemd1': timed out

--- Update:
The dbus services comes with systemd... So maybe systemd and dbus 1.6 aren't kompatible?

Before you may ask, here is "pacman -Qii systemd":

Name : systemd
Version : 185-3
URL : http://www.freedesktop.org/wiki/Software/systemd
Licenses : GPL2 LGPL2.1 MIT
Groups : None
Provides : None
Depends On : acl dbus-core libsystemd=185 kmod libcap pam
systemd-tools=185 util-linux xz
Optional Deps : python2-dbus: systemd-analyze
initscripts: legacy support for hostname and vconsole setup
initscripts-systemd: native boot and initialization scripts
python2-cairo: systemd-analyze
systemd-arch-units: collection of native unit files for Arch
daemon/init scripts
systemd-sysvcompat: symlink package to provide sysvinit
binaries
Required By : initscripts-systemd systemd-arch-units
Conflicts With : None
Replaces : None
Installed Size : 3996.00 KiB
Packager : Dave Reisner <dreisner@archlinux.org>
Architecture : x86_64
Build Date : Mon Jun 25 03:08:09 2012
Install Date : Mon Jun 25 13:00:05 2012
Install Reason : Installed as a dependency for another package
Install Script : Yes
Description : system and service manager
Backup Files:
UNMODIFIED /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
UNMODIFIED /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
UNMODIFIED /etc/dbus-1/system.d/org.freedesktop.login1.conf
UNMODIFIED /etc/dbus-1/system.d/org.freedesktop.locale1.conf
UNMODIFIED /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
UNMODIFIED /etc/systemd/system.conf
UNMODIFIED /etc/systemd/user.conf
UNMODIFIED /etc/systemd/logind.conf
UNMODIFIED /etc/systemd/journald.conf

Comment by Pyro Devil (PyroDevil) - Thursday, 28 June 2012, 17:33 GMT
I activated the testing repositories and tried dbus 1.6.2, but with no success.
Dbus fails to activate some services:

Jun 28 19:11:19 Primat dbus[510]: [system] Failed to activate service 'fi.w1.wpa_supplicant1': timed out
Jun 28 19:11:19 Primat dbus[510]: [system] Failed to activate service 'org.freedesktop.systemd1': timed out
Jun 28 19:11:47 Primat dbus[579]: [system] Failed to activate service 'org.bluez': timed out
Jun 28 19:12:12 Primat dbus[605]: [system] Failed to activate service 'org.freedesktop.login1': timed out
Comment by Ionut Biru (wonder) - Thursday, 28 June 2012, 17:35 GMT
what version of dbus-core?
Comment by Pyro Devil (PyroDevil) - Thursday, 28 June 2012, 19:43 GMT
always the matching with the newest pkgrel
Comment by Tobias Powalowski (tpowa) - Thursday, 28 June 2012, 19:44 GMT
1.6.2-2?
Comment by Ionut Biru (wonder) - Thursday, 28 June 2012, 19:54 GMT
I'm sorry Pyro but I cannot parse "newest pkgrel" or "latest version"
Comment by Pyro Devil (PyroDevil) - Thursday, 28 June 2012, 20:13 GMT
dbus-core 1.6.2-2
dbus 1.6.2-1
Comment by Ionut Biru (wonder) - Thursday, 28 June 2012, 20:22 GMT
it should work with -2. Are you sure you have tested properly with that version? as in rebooting your system.
Comment by Pyro Devil (PyroDevil) - Thursday, 28 June 2012, 20:49 GMT
Jep, I rebooted. I got this information from pacman.log:
[2012-06-28 18:35] upgraded dbus-core (1.4.20-2 -> 1.6.2-2)
[2012-06-28 18:35] upgraded dbus (1.4.20-1 -> 1.6.2-1)
Comment by Ionut Biru (wonder) - Thursday, 28 June 2012, 20:53 GMT
What's your login method into your graphical environment?
Comment by Pyro Devil (PyroDevil) - Thursday, 28 June 2012, 21:06 GMT
I'm not sure what you ask, but I try to answer:
systemd starts gdm.service
There I type my password (so not autologin or fingerprint reading)
And then gnome-shell starts
Everything is local, so no ssh login etc.
It's my laptop, so a "standard desktop system"
Comment by Ionut Biru (wonder) - Thursday, 28 June 2012, 21:10 GMT
are the gdm pam modules modified by any chance?
pacman -Qii gdm | grep etc
Comment by Pyro Devil (PyroDevil) - Thursday, 28 June 2012, 21:19 GMT
I already posted the whole output of "pacman -Qii gdm", but here is this part again:

UNMODIFIED /etc/pam.d/gdm-autologin
UNMODIFIED /etc/pam.d/gdm-fingerprint
UNMODIFIED /etc/pam.d/gdm
UNMODIFIED /etc/pam.d/gdm-password
UNMODIFIED /etc/pam.d/gdm-smartcard
UNMODIFIED /etc/pam.d/gdm-welcome
MODIFIED /etc/gdm/custom.conf

(Thats my last message for today, but I'm here again tomorrow)
Comment by Jiri Brachtl (paladin) - Friday, 29 June 2012, 04:03 GMT
Update from dbus 1.4 to 1.6 also affects slim in the same way ... x server starts but screen is black and the mousepointer is a watch.

/var/log/slim.log contains:
slim: open_session: Unable to open session: Message did not receive a reply (timeout by message bus)
Comment by Pyro Devil (PyroDevil) - Friday, 29 June 2012, 06:42 GMT
I tried slim now.
First with dbus 1.4.20-1 and dbus-core 1.4.20-2:
It works flawless. Greeter appears, login and gnome-session with gnome-shell starts.

Then I tried it with dbus 1.6.2-1 and dbus-core 1.6.2-2:
Greeter appears, I can type my username and password but after pressing enter and some loading time I get to the tty1.

Here some error messages in the slim.log file:
slim: open_session: Unable to open session: Activation of org.freedesktop.ConsoleKit timed out
slim: open_session: Unable to open session: Connection was disconnected before a reply was received

I used a minimal slim configuration, so I only configured it, that it starts gnome-session.
Maybe Jiri configured slim with gnome-keyring support.

Comment by Ionut Biru (wonder) - Friday, 29 June 2012, 16:41 GMT
can yo do ls /run/console when using dbus 1.6.2?
Comment by Pyro Devil (PyroDevil) - Friday, 29 June 2012, 17:10 GMT
There is no output.
Comment by A.C. (zepar) - Saturday, 30 June 2012, 12:59 GMT Comment by Pyro Devil (PyroDevil) - Saturday, 30 June 2012, 14:36 GMT
Neighter `systemd-machine-id-setup` nor `dbus-uuidgen > /etc/machine-id` fixed the problem.
Comment by Yury Afanasyev (0x00deaf) - Saturday, 30 June 2012, 17:31 GMT
Same issue here. I did fresh installation of archlinux and after upgrade gdm as well as nm-applet can't find dbus session.
Rolled back to dbus 1.4 as Ticket owner suggested - it worked. Can provide logs/cmd outputs if you need.
Tried kdm/slim - it works fine with dbus 1.6
Comment by Yury Afanasyev (0x00deaf) - Sunday, 01 July 2012, 04:51 GMT
Problem is fixed for me. I'm running dbus 1.6 now without any problems with NM or GDM.
For me it was because of filesystem package upgrade issues and /etc/group.pacnew file was not resolved for me.
I've noticed that dbus group is not anymore exist in group so I resolved /etc/group file and rebooted

PS. Some issues with 'filesystem' package upgrade: I removed /var/run directory to be able to install it.

After those steps I was able to work with dbus 1.6 version. Please check if you can solve it this way.
Comment by Pyro Devil (PyroDevil) - Sunday, 01 July 2012, 06:51 GMT
I already updated the filesystem package with the force option and it did work that time.
With your remark I did the following: `rm -rf /var/run /var/lock && pacman -S filesystem` to reinstall the filesystem package.
Then updated to dbus 1.6, rebooted and it works.

Thanks for all your help!

Loading...