Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30417 - [linux] Nouveau triggers kernel BUG in slub.c on GTX 560 Ti

Attached to Project: Arch Linux
Opened by WorMzy Tykashi (WorMzy) - Saturday, 23 June 2012, 17:32 GMT
Last edited by Tobias Powalowski (tpowa) - Tuesday, 17 July 2012, 14:52 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Upstream bug, reported here[1].


Additional info:
Affects all kernels after and including 3.4rc1. Hasn't caused any noise on the forum, but reporting it here to make Arch devs aware of it. Unconfirmed on i686. Patch attached (re-adds an "unused" variable to struct drm_fb_helper_crtc).


Steps to reproduce:
Have a GTX 560 Ti, install any kernel from the 3.4 or 3.5 series, then try to boot.


[1]https://bugs.freedesktop.org/show_bug.cgi?id=51018
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Tuesday, 17 July 2012, 14:52 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.4.5-1
Comment by Ionut Biru (wonder) - Saturday, 23 June 2012, 18:06 GMT
that's why my display is not turn on anymore with nouveau?
Comment by WorMzy Tykashi (WorMzy) - Saturday, 23 June 2012, 18:24 GMT
Possibly. Do you have a GTX 560? Everyone that's reported this bug so far does, but maybe there's other cards with the same problem.

There's a similar bug[2] affecting some laptop models. There's a link to a patch for that in the comments.

[2]https://bugs.freedesktop.org/show_bug.cgi?id=50175
Comment by Ionut Biru (wonder) - Saturday, 23 June 2012, 18:25 GMT
yes
01:00.0 VGA compatible controller: NVIDIA Corporation GF114 [GeForce GTX 560] (rev a1)
Comment by WorMzy Tykashi (WorMzy) - Saturday, 23 June 2012, 18:41 GMT
It probably is then. You could check whether booting with the slub_debug kernel parameter lets you boot, that would confirm it's the same bug imo.

Try rebuilding the kernel with the patch I attached. It's worked for me and at least two other users so far.
Comment by WorMzy Tykashi (WorMzy) - Thursday, 28 June 2012, 20:02 GMT
  • Field changed: Percent Complete (100% → 0%)
Fix proposed upstream differs from current fix: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=commitdiff;h=9bd0c15fcfb42f6245447c53347d65ad9e72080b;hp=d42f0349f3fed647c61c2d432e974bbdafcfb3fb

Haven't tested it yet.

It's expected to be applied upstream by 3.4.5, so it may be worth holding off modifying the PKGBUILD until then, then just dropping the gtx560ti patch (not sure if it affects the laptop backlight bug)
Comment by Ionut Biru (wonder) - Thursday, 28 June 2012, 20:13 GMT
We know about it, I actually helped debugging that issue properly :D.
Comment by WorMzy Tykashi (WorMzy) - Thursday, 28 June 2012, 22:06 GMT
I noticed that, I'm glad you were able to get to the bottom of the problem. Good work, to you and everyone involved! :)

I can confirm that the patch works for me.
Comment by Szabo Istvan (szaboi) - Saturday, 14 July 2012, 14:10 GMT
Thank You very much for your work!

Loading...