Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30389 - Postresql errors on install

Attached to Project: Community Packages
Opened by Alexander Kyte (sublimepua) - Wednesday, 20 June 2012, 19:21 GMT
Last edited by Eric Belanger (Snowman) - Wednesday, 20 June 2012, 21:57 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When installing:
postgresql-libs-9.1.4-1 postgresql-9.1.4-1

I got an error after the installation step

/tmp/alpm_6ATKS7/.INSTALL: line 5: groupadd: command not found
/tmp/alpm_6ATKS7/.INSTALL: line 6: useradd: command not found
passwd: user 'postgres' does not exist
error: command failed to execute correctly

as I'm not afraid to add them myself, this isn't that worrisome. To someone who didn't notice the error or who use archlinux as a webdev box or used an automated installer, this could be quite the burden.
This task depends upon

Closed by  Eric Belanger (Snowman)
Wednesday, 20 June 2012, 21:57 GMT
Reason for closing:  Not a bug
Comment by Eric Belanger (Snowman) - Wednesday, 20 June 2012, 21:57 GMT
These binaries are in shadow which is in base group. We assume users have base installed.

Loading...