Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30361 - [netcfg] 2.8.4 fails to start with systemd

Attached to Project: Arch Linux
Opened by Andreas Radke (AndyRTR) - Tuesday, 19 June 2012, 15:32 GMT
Last edited by Jouke Witteveen (jouke) - Monday, 25 June 2012, 13:54 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jouke Witteveen (jouke)
Architecture All
Severity Medium
Priority High
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

since netcfg 2.8.4 update my ethernet static profile won't come up anymore:

netcfg.service - Netcfg multi-profile daemon
Loaded: loaded (/usr/lib/systemd/system/netcfg.service; enabled)
Active: failed (Result: exit-code) since Sat, 16 Jun 2012 11:50:00 +0200; 2min 34s ago
Process: 336 ExecStart=/usr/bin/netcfg-daemon start (code=exited, status=1/FAILURE)
CGroup: name=systemd:/system/netcfg.service

Jun 16 11:50:00 workstation64 netcfg-daemon[336]: :: ethernet-static up No co...
Jun 16 11:50:00 workstation64 netcfg-daemon[336]: [fail]
This task depends upon

Closed by  Jouke Witteveen (jouke)
Monday, 25 June 2012, 13:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  5ac72
Comment by Jouke Witteveen (jouke) - Tuesday, 19 June 2012, 15:46 GMT
Please set CARRIER_TIMEOUT to 4 or higher and report back. This could be a side effect of http://projects.archlinux.org/netcfg.git/commit/?id=4255f
Comment by Tobias Powalowski (tpowa) - Thursday, 21 June 2012, 06:48 GMT
CARRIER_TIMEOUT=5 solved the issue for me.
Comment by Jouke Witteveen (jouke) - Thursday, 21 June 2012, 09:18 GMT
Was 5 the lowest value for which the issue was solved? In the old situation, `bring_interface up` would always wait 2 seconds, in the new situation it waits until the interface is up. This means it would arrive at the `sleep ${CARRIER_TIMEOUT:-2}` at most two seconds sooner, which suggests that `CARRIER_TIMEOUT=4` solves the problem if the changes to bring_interface are really at fault.

This is just to verify I know the root cause of the problem. In 2.8.5 CARRIER_TIMEOUT handling will be improved, which should solve this bug.
Comment by Tobias Powalowski (tpowa) - Thursday, 21 June 2012, 09:31 GMT
It's my headless server 5 was ok 4 not tested. I don't want to take my monitor and keyboard to it again.
Comment by Jens Adam (byte) - Sunday, 24 June 2012, 04:57 GMT
CARRIER_TIMEOUT=5 fixed it for me, too. (no systemd, ethernet-dhcp)

dmesg:
[ 18.527946] r8169 0000:02:00.0: eth0: link down
[ 18.527969] r8169 0000:02:00.0: eth0: link down
[ 18.527976] NOHZ: local_softirq_pending 08
[ 18.528860] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 20.738458] r8169 0000:02:00.0: eth0: link up
[ 20.739314] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Comment by Andreas Radke (AndyRTR) - Sunday, 24 June 2012, 07:47 GMT
Where do you put this var? Into the profile file?
Comment by Jens Adam (byte) - Sunday, 24 June 2012, 12:47 GMT
Line in the profile, yes.
Comment by Jouke Witteveen (jouke) - Sunday, 24 June 2012, 22:17 GMT
Is this fixed in 2.8.5?
Comment by Tobias Powalowski (tpowa) - Monday, 25 June 2012, 06:57 GMT
For me yes.
Comment by Jens Adam (byte) - Monday, 25 June 2012, 07:33 GMT
Yup, 2.8.5 is alright.
Comment by Andreas Radke (AndyRTR) - Monday, 25 June 2012, 13:41 GMT
I'm currently not using it on the system where it failed. Feel free to close this one.

Loading...