Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30345 - [hplip] foomatic-rip-hplip value

Attached to Project: Arch Linux
Opened by Iohan THERY (karhu) - Monday, 18 June 2012, 20:11 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 22 July 2012, 12:15 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Tom Gundersen (tomegun)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
With the package hplip-plugin 3.12.4 we got an error message with HP printers.
File "/usr/lib/cups/filter/foomatic-rip-hplip" not available: No such file or directory
To fix it in the PKGBUILD the option foomatic-rip-hplip-install must be yes.
The best way is to change in the PKGBUILD
--disable-foomatic-rip-hplip-install \
with
--enable-foomatic-rip-hplip-install \

Additional info:

Already see in Ubuntu two years ago.

Steps to reproduce:
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 22 July 2012, 12:15 GMT
Reason for closing:  Not a bug
Additional comments about closing:  a broken custom pkg
Comment by Andreas Radke (AndyRTR) - Tuesday, 19 June 2012, 16:18 GMT
foomatic-rip-hplip has been removed for good reasons to work together with recent cups-filters based pdf printing workflow.

Please make sure your system is fully up to date (-Syu). Check your cups pkg version.
Comment by Iohan THERY (karhu) - Tuesday, 19 June 2012, 20:18 GMT
My linux version 3.4.2-2
My cups version 1.5.3-5
My hplip version 3.12.4-4 (modified)
I did yaourt -Syu and it has a new version for Linux but neither for cups and hplip-plugin.
Comment by Sergey Kolesov (cucullus) - Friday, 22 June 2012, 09:41 GMT
Same here. Printing failed intil ln foomatic-rip-hplip -> foomatic-rip
Comment by Andreas Radke (AndyRTR) - Friday, 22 June 2012, 13:49 GMT
Are you using custom ppds? Please check where your driver calls foomatic-rip-hplip.

We have fix in our PKGBUILD that should make all ppds work with cups-filters / foomatic-rip. See


# https://bugs.archlinux.org/task/30085 - hack found in Gentoo
# Use system foomatic-rip for hpijs driver instead of foomatic-rip-hplip
# The hpcups driver does not use foomatic-rip
local i
for i in ppd/hpijs/*.ppd.gz ; do
rm -f ${i}.temp
gunzip -c ${i} | sed 's/foomatic-rip-hplip/foomatic-rip/g' | \
gzip > ${i}.temp || return 1
mv ${i}.temp ${i}
done
Comment by Sergey Kolesov (cucullus) - Monday, 25 June 2012, 21:09 GMT
Nope. Standart HP LJ 1320 via smb.

E [14/Jun/2012:13:54:43 +0400] HP_LJ_1320: File "/usr/lib/cups/filter/foomatic-rip-hplip" not available: No such file or directory
E [14/Jun/2012:13:54:43 +0400] HP_LJ_1320: File "/usr/lib/cups/filter/foomatic-rip-hplip" not available: No such file or directory
E [21/Jun/2012:18:57:46 +0400] HP_LJ_1320: File "/usr/lib/cups/filter/foomatic-rip-hplip" not available: No such file or directory
E [21/Jun/2012:18:57:46 +0400] [Job 63] Unable to start filter "foomatic-rip-hplip" - No such file or directory.
E [21/Jun/2012:18:57:46 +0400] [Job 63] Stopping job because the scheduler could not execute a filter.
E [21/Jun/2012:19:02:47 +0400] [Job 63] Stopping unresponsive job!
Comment by Sergey Kolesov (cucullus) - Monday, 25 June 2012, 21:17 GMT
Hmm. I'm using foomatic-db-foo2zjs.
Comment by Andreas Radke (AndyRTR) - Tuesday, 26 June 2012, 16:07 GMT
Then that's a bug in your custom pkg. Use some sed command or patch to fix it in your custom *.ppd.gz.

I assume the same for the initial reporter saying he's using a modified hplip version.

Loading...