Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.

FS#30343 - Bug/annoyance with --downloadonly not working with Ignorepkg.

Attached to Project: Pacman
Opened by Scott (fu-fu) - Monday, 18 June 2012, 18:23 GMT
Last edited by Allan McRae (Allan) - Tuesday, 29 March 2016, 10:10 GMT
Task Type General Gripe
Category General
Status Closed
Assigned To Allan McRae (Allan)
Architecture x86_64
Severity Low
Priority Normal
Reported Version 4.0.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


Summary and Info:
Running pacman with a Ignorepkg=<package> will prompt weather or not you want to install that updated package (I assume only if there is an update) However, with the option -w added, it will not prompt, and try to install the latest.

I was trying to get a ppc install of arch in a folder so that I could put it on my wii, Glibc was over-updated(?) and was requiring linux-api-headers 3.2 while the repos only had 3.1.6, I got a version of glibc from a previous attempt at trying this (It was for 3.1.6). I was trying to make it so that if the setup failed I wouldn't have to re download the cache (the -w option), It kept trying to update Glibc regardless of Noupgrade=glibc and Ignorepkg=glibc set in the pacman.conf. However, without the -w option, it questions weather you want to update it, and will then proceed.

Steps to Reproduce:
Get version of a package that's not the newest and has a missing dependency (or over-updated), pacman -Syw <package>, it will give: warning: cannot resolve <dependency package>, a dependency of <package>. However without the -w option, it will prompt if you want to update it.
This task depends upon

Closed by  Allan McRae (Allan)
Tuesday, 29 March 2016, 10:10 GMT
Reason for closing:  Not a bug
Comment by Allan McRae (Allan) - Saturday, 09 February 2013, 04:19 GMT
See duplicate  FS#32652  for a better explanation. In summary, -Sw does not consider --ignore
Comment by Allan McRae (Allan) - Tuesday, 29 March 2016, 10:10 GMT
--ignore/IgnorePkg are working as documented. Make the equivalent of "pacman -Sw foo --ignore foo" work makes little sense.