Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30342 - [netcfg] 2.8.3-1 fails to deal with essid containing accents and quotes

Attached to Project: Arch Linux
Opened by Luck Darnière (LuX) - Monday, 18 June 2012, 16:12 GMT
Last edited by Jouke Witteveen (jouke) - Sunday, 24 June 2012, 22:26 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jouke Witteveen (jouke)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
I have been unable to connect, via wifi-menu and/or netcfg 2.8.3-5, to a wifi spot with essid "Wifi du château d'Olonne" and no encryption.
This essid was properly presented by 'iwlist wlan0 scan'.
It was unproperly converted to "ch_teau d'Olonne" when wifi-menu created a profile for this wifi spot.
Moreover netcfg was puzzled by the single quote in "d'Olonne", even after I tried to replace it by "d\'Olonne" in the profile.

Additional info:
* package version(s)
* config and/or log files etc.

I had the same problem with wpa_supplicant 0.7.3-5 (which is not the latest stable version, but the package in Arch is out-of-date at the moment), although the essid field in wpa_supplicant.conf is written between double quotes (instead of single quote in netcfg profiles). I have posted more detailed information and output in the forum:
http://forums.archlinux.fr/post96296.html#p96296

Steps to reproduce:
Find a wifi spot with essid containing non-ascii characters and single quotes.
This task depends upon

Closed by  Jouke Witteveen (jouke)
Sunday, 24 June 2012, 22:26 GMT
Reason for closing:  Fixed
Additional comments about closing:  5e6d2 (and 5ac72)
Comment by Jouke Witteveen (jouke) - Monday, 18 June 2012, 23:53 GMT
Could you test the attached patch? It should at least solve the problem with the quote. I don't know what causes the accented character to be replaced by an underscore yet.
Comment by Luck Darnière (LuX) - Saturday, 23 June 2012, 21:36 GMT
I can't go easily to the wifi spot "Château d'Olonne" but I can change the essid of my own box. Thus I have included some single quotes in the essid of my box, and indeed wifi-menu modified by your patch worked as well as netcfg. However:

1) I haven't been able to test what happens with non-ascii characters such as "â" because such characters are not authorized by the configuration page of my box.

2) Errors still occur when turning off the wifi with netcfg, or to switch to another wifi using wifi-menu.

- With one quote:

# netcfg down wlan0-wifi\'test
/run/network/interfaces/wlan0: ligne1: Caractère de fin de fichier (EOF) prématuré lors de la recherche du « ' » correspondant
/run/network/interfaces/wlan0: ligne2: Erreur de syntaxe : fin de fichier prématurée
:: wlan0-wifi'test down [BUSY]
/run/network/interfaces/wlan0: ligne1: Caractère de fin de fichier (EOF) prématuré lors de la recherche du « ' » correspondant
/run/network/interfaces/wlan0: ligne2: Erreur de syntaxe : fin de fichier prématurée
[DONE]
- With two quotes:

# netcfg down wlan0-wifi\'t\'test
> Profile not connected

Comment by Jouke Witteveen (jouke) - Sunday, 24 June 2012, 22:26 GMT
Thanks for the report and testing. I will close this report because the quotes problem is fixed in 2.8.5.
I think the accented characters problem might be either none existent or due to mangled output from 'wpa_cli (...) scan_results', in which case it is not a bug in netcfg.
If there are reasons to believe there exists an accented characters bug and it is in fact in netcfg, let me know.

Loading...