Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30279 - [qemu-kvm] segfaults when guest network is probed before it is up

Attached to Project: Arch Linux
Opened by Gaetan Bisson (vesath) - Wednesday, 13 June 2012, 11:31 GMT
Last edited by Gaetan Bisson (vesath) - Monday, 18 June 2012, 04:51 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When I run qemu-kvm with the options to forward a port from the host to a port on the guest, such as:

qemu-kvm -net nic,model=virtio -net user,hostfwd=tcp::7272-:22 arch.img

And, in parallel, as soon qemu-kvm is running, while the guest is still in the early bootloader stages, I run (still on the host):

telnet localhost 7272

Then qemu-kvm segfaults a couple of seconds later when the guest is apparently trying to set networking up; see the GDB session attached for a backtrace.

In fact, this happens deterministically when anything (telnet, ncat, ssh, etc.) tries to connect to the guest early on, and it does not matter either whether something is actually listening on port 22 of the guest.
   bt.txt (3.3 KiB)
This task depends upon

Closed by  Gaetan Bisson (vesath)
Monday, 18 June 2012, 04:51 GMT
Reason for closing:  Upstream
Comment by Tobias Powalowski (tpowa) - Wednesday, 13 June 2012, 12:44 GMT
Not sure what I can do there, new 1.1.0 version will come soon perhaps it will fix this.
Comment by Gaetan Bisson (vesath) - Wednesday, 13 June 2012, 12:55 GMT
Great. I just wanted your opinion before possibly reporting this upstream; I'll wait for 1.1.0 and see if it's fixed there.
Comment by Gaetan Bisson (vesath) - Monday, 18 June 2012, 04:51 GMT
That seems fixed with qemu-kvm-1.1-rc4; thanks.

Loading...