Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#30244 - After upgrading of initscripts the console font is broken

Attached to Project: Arch Linux
Opened by Gennady (Leonardo19) - Monday, 11 June 2012, 09:36 GMT
Last edited by Allan McRae (Allan) - Saturday, 16 June 2012, 07:31 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture i686
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


After last upgrading of initscripts the console font is broken.
I have nvidia driver installed, my locale is ru_RU.UTF-8. When log in to TTY1...6 no cyrillic characters can be seen. And it is impossible to change keyboard layout to cyrillic.

Additional info:
initscripts 2012.06.1-1
Settings in /etc/rc.conf:

Steps to reproduce:
Log in to TTY1 and try to input any cyrillic characters (change layout Shift+Ctl).
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 16 June 2012, 07:31 GMT
Reason for closing:  None
Additional comments about closing:  Workaround is to change console font
Comment by Gennady (Leonardo19) - Monday, 11 June 2012, 11:25 GMT
Changing consolefont to cyr-sun16 solved the problem.
Comment by Anonymous (reallybmn) - Monday, 11 June 2012, 19:38 GMT
I have the same problem. And roughly same settings, except that I already use cyr-sun16 and switching it the other way to ruscii (just in case) didn't help. (I also use radeon driver, for ATI.) Also cyrillic text printed by programs displays as random nonsense, like in  FS#30228 . I blindly tried to apply patch suggested there, yet it didn't help, too. Had to downgrade initscripts after all.
Comment by Gabriel Fretes (g_fretes) - Tuesday, 12 June 2012, 00:16 GMT
It's only me... or now the initscripts package (not initscripts-systemd) needs systemd to work well at starting??? Before the update that you say, my console are unconfigured, ignoring the content of rc.conf and even vconsole.conf.
Comment by Sergio (NetMould) - Tuesday, 12 June 2012, 21:12 GMT
I had the same problem after the last update. My rc.conf was configured in 2011 and was good for all this time. I've used cyr-sun16 from the begining, but after this update, my console looks ugly. So i took the rc.conf.pacnew file, configure it like previous rc.conf and save it as rc.conf. After reboot my console font works again. I'm not shure, but may be something wrong with old file.
And I don't know why, but this problem was actual only for one of my computers (hp mini 2133).
Comment by Gennady (Leonardo19) - Wednesday, 13 June 2012, 08:33 GMT
Maybe it can help someway: besides consolefont I changed DAEMON_LOCALE from "no" to "yes" in rc.conf. But setfont ruscii_8x16 breaks cyrillic all the same.
Comment by Anonymous (reallybmn) - Thursday, 14 June 2012, 14:57 GMT
It did help indeed, thanks! But being unable to switch language without switching DAEMON_LOCALE first is probably still a bug, albeit more minor one? Well, I don't care. Thank you again.