Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30233 - [heirloom-mailx] mailx creates hundreds of processes and computer hangs

Attached to Project: Arch Linux
Opened by Andrea Amorosi (AndreaA) - Sunday, 10 June 2012, 11:20 GMT
Last edited by Stéphane Gaudreault (stephane) - Monday, 11 June 2012, 10:03 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Stéphane Gaudreault (stephane)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
If I try to send a mail to a local user with the following command
mailx -s "test" -v root followed by a dot to terminate the message

I can see hundreds of mailx processes which causes the computer to become irresponsive and I've to shutdown the pc to be able to kill all of them.
After the reboot I can see a dead.letter in my user home like in the attachment.

Additional info:
* package version(s)
heirloom-mailx 12.5-3
* config and/or log files etc.
mail.rc in attachment

Steps to reproduce:
execute the following command:
mailx -s "test" -v root followed by a dot to terminate the message
This task depends upon

Closed by  Stéphane Gaudreault (stephane)
Monday, 11 June 2012, 10:03 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Users should not call mailx recursively. They should install an smtp-forwarder (ex extra/msmtp-mta).
Comment by Stéphane Gaudreault (stephane) - Sunday, 10 June 2012, 15:21 GMT
Why do you have

set sendmail="/usr/bin/mailx"

at the end of your mail.rc file ?

mailx is not an smtp forwarder ...

You should probably use one of these instead

pacman -Ss smtp-forwarder
extra/msmtp-mta 1.4.28-1 [installé]
A mini smtp client - the regular MTA
extra/postfix 2.9.3-1
Fast, easy to administer, secure mail server
extra/ssmtp 2.64-3
Extremely simple MTA to get mail off the system to a mailhub
community/courier-mta 0.68.1-1
IMAP(s)/POP3(s) and SMTP Server with ML-manager, webmail and webconfig
community/esmtp 1.2-4
An easy SMTP forwarder.
Comment by Andrea Amorosi (AndreaA) - Sunday, 10 June 2012, 17:40 GMT
I've found it on a forum.
However since I need only to send the result of a script to a local mai (/var/spool/mail/username) which of the programs best fit my case?
Thank you,
Andrea Amorosi

Loading...