Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#3022 - pam compiled with invalid CRACKLIB_DICTPATH

Attached to Project: Arch Linux
Opened by Jürgen Hötzel (juergen) - Monday, 01 August 2005, 13:21 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To Judd Vinet (judd)
Architecture not specified
Severity Low
Priority Normal
Reported Version 0.7 Wombat
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

This seems to be a leftover from days when pam was bundled with cracklib. Try the following /etc/pam.d/passwd

password required pam_cracklib.so retry=3 debug
password sufficient pam_unix.so shadow md5 nullok use_authtok
password required pam_deny.so

And you will get the following error when changing executing /usr/bin/passwd:

Aug 1 11:49:59 myhost PAM-Cracklib[426]: dict path ''[.pwd] is invalid

Patch enclosed
This task depends upon

Closed by  Judd Vinet (judd)
Wednesday, 24 August 2005, 22:42 GMT
Reason for closing:  Fixed
Comment by Tobias Kieslich (tobias) - Monday, 01 August 2005, 21:26 GMT
Thanks Jürgen, I will take care of pam tomorrow anyway and release a new version to testing tomorrow. So I will incorporate that.
Comment by Tobias Kieslich (tobias) - Tuesday, 02 August 2005, 10:53 GMT
I just saw that Judd already fixed that in the testing versions. So technically it's done, we just wait until the necxt testing cycle hits the repos.

Loading...