Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30180 - [libgda] installs /config in filesystem root

Attached to Project: Arch Linux
Opened by Marti (intgr) - Thursday, 07 June 2012, 19:24 GMT
Last edited by Jan Alexander Steffens (heftig) - Wednesday, 20 June 2012, 19:12 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: Packages shouldn't install random stuff into the file system root directory.

Steps to reproduce:
pacman -S libgda
ls -la /config
-rw-r--r-- 1 root root 2720 Apr 26 2010 /config

Additional info:
* package version(s)
libgda 5.0.3-1
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Wednesday, 20 June 2012, 19:12 GMT
Reason for closing:  Deferred
Additional comments about closing:  Please refile a bug against pacman.
Comment by Marti (intgr) - Thursday, 07 June 2012, 22:16 GMT
And now I'm confused... I installed libgda on another computer and /config does not appear.

But on the 1st machine, it's certainly owned by libgda:
% pacman -Qo /config
/config is owned by libgda 5.0.3-1

What gives?
Comment by Jan de Groot (JGC) - Friday, 08 June 2012, 11:00 GMT
ls -la /etc/libgda-5.0

The /config file should be there, but I suppose your system has a symlink to / in that place.
Comment by Marti (intgr) - Wednesday, 20 June 2012, 18:49 GMT
Sorry about not replying before. Strangely enough, it's not a link...

% ls -la /etc/libgda-5.0
total 52
drwxr-xr-x 2 root root 4096 Mar 30 14:33 .
drwxr-xr-x 120 root root 12288 Jun 20 20:43 ..
-rw-r--r-- 1 root root 100 Mar 30 14:33 config
-rw-r--r-- 1 root root 32768 Mar 30 14:33 sales_test.db

% stat /etc/libgda-5.0 /etc/libgda-5.0/config /config
File: ‘/etc/libgda-5.0’
Size: 4096 Blocks: 8 IO Block: 4096 directory
Device: 803h/2051d Inode: 1589891 Links: 2
Access: (0755/drwxr-xr-x) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2012-03-30 22:16:05.000000000 +0300
Modify: 2012-03-30 14:33:08.000000000 +0300
Change: 2012-03-30 22:16:05.942985340 +0300
Birth: -
File: ‘/etc/libgda-5.0/config’
Size: 100 Blocks: 8 IO Block: 4096 regular file
Device: 803h/2051d Inode: 1573179 Links: 1
Access: (0644/-rw-r--r--) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2012-03-30 22:16:05.000000000 +0300
Modify: 2012-03-30 14:33:08.000000000 +0300
Change: 2012-03-30 22:16:05.235965340 +0300
Birth: -
File: ‘/config’
Size: 2720 Blocks: 8 IO Block: 4096 regular file
Device: 803h/2051d Inode: 14 Links: 1
Access: (0644/-rw-r--r--) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2010-04-26 22:56:14.620584853 +0300
Modify: 2010-04-26 22:56:14.620584853 +0300
Change: 2010-04-26 22:56:14.620584853 +0300
Birth: -

% pacman -Qo /config /etc/libgda-5.0/config
/config is owned by libgda 5.0.3-1
/etc/libgda-5.0/config is owned by libgda 5.0.3-1
Comment by Marti (intgr) - Wednesday, 20 June 2012, 18:52 GMT
In fact, /config is a copy of my /etc/mkinitcpio.conf for some reason: http://codepad.org/GaoHwdeg

This is really weird!
Comment by Jan Alexander Steffens (heftig) - Wednesday, 20 June 2012, 18:56 GMT
Sounds like a messed-up database. What's in /var/lib/pacman/local/libgda-5.0.3-1/files ?
Comment by Marti (intgr) - Wednesday, 20 June 2012, 18:59 GMT
Contents of /var/lib/pacman/local/libgda-5.0.3-1/files : http://codepad.org/H5t0oFZh

Looks like the database is OK, no /config there. Is there a bug in pacman -Qo?
Comment by Marti (intgr) - Wednesday, 20 June 2012, 19:04 GMT
Yeah, I can reproduce it now:
pacman -S libgda
cp /etc/mkinitcpio.conf /config
pacman -Qo /config

Loading...