Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30074 - pacman optional dependencies info

Attached to Project: Arch Linux
Opened by Jakub Bittner (rexcze) - Wednesday, 30 May 2012, 11:56 GMT
Last edited by Allan McRae (Allan) - Wednesday, 30 May 2012, 12:22 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

While installing or upgrading packages some of them gives hints with optional dependencies. Pacman should check if those dependecies are already installed and should not show them. = Just show uninstalled dependencies.


example:

pacman -S cups-filters
Optional dependencies for cups-filters:
ghostscript: for non-PostScript printers to print with CUPS to convert PostScript to raster images
foomatic-db: drivers use Ghostscript to convert PostScript to a printable form directly
foomatic-db-engine: drivers use Ghostscript to convert PostScript to a printable form directly
foomatic-db-nonfree: drivers use Ghostscript to convert PostScript to a printable form directly

It could be like this:
pacman -S cups-filters
Optional dependencies for cups-filters:
foomatic-db-nonfree: drivers use Ghostscript to convert PostScript to a printable form directly

Because other are already installed.

OR

pacman -S cups-filters
Optional dependencies for cups-filters:
ghostscript: for non-PostScript printers to print with CUPS to convert PostScript to raster images [INSTALLED]
foomatic-db: drivers use Ghostscript to convert PostScript to a printable form directly [INSTALLED]
foomatic-db-engine: drivers use Ghostscript to convert PostScript to a printable form directly [INSTALLED]
foomatic-db-nonfree: drivers use Ghostscript to convert PostScript to a printable form directly
This task depends upon

Closed by  Allan McRae (Allan)
Wednesday, 30 May 2012, 12:22 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Wrong section and duplicate of several bugs in the right section...

Loading...