Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30065 - [linux] 3.4.0 rtl8192ce connection problems

Attached to Project: Arch Linux
Opened by Roberto Catini (robcat) - Tuesday, 29 May 2012, 17:40 GMT
Last edited by Tobias Powalowski (tpowa) - Thursday, 14 June 2012, 05:32 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Using linux 3.4-1, no internet connection can be estabilished.
On my system dmesg printed endless tries like these:

[ 9.849826] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 13.169601] wlan0: authenticate with 00:24:89:43:b1:cf
[ 13.189577] wlan0: send auth to 00:24:89:43:b1:cf (try 1/3)
[ 13.392059] wlan0: send auth to 00:24:89:43:b1:cf (try 2/3)
[ 13.595334] wlan0: send auth to 00:24:89:43:b1:cf (try 3/3)
[ 13.798541] wlan0: authentication with 00:24:89:43:b1:cf timed out
[ 20.045878] wlan0: authenticate with 00:24:89:43:b1:cf
[ 20.065922] wlan0: send auth to 00:24:89:43:b1:cf (try 1/3)
[ 20.268608] wlan0: send auth to 00:24:89:43:b1:cf (try 2/3)
[ 20.471807] wlan0: send auth to 00:24:89:43:b1:cf (try 3/3)
[ 20.675062] wlan0: authentication with 00:24:89:43:b1:cf timed out

lspci -nn | grep net
01:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR8152 v2.0 Fast Ethernet [1969:2062] (rev c1)

The solution at https://bbs.archlinux.org/viewtopic.php?pid=1107433#p1107433 (disable power saving features) worked for me an hour ago; then I switched to systemd deleting the modprobe.d folder and now the connection seems stable.

Othert relevant forum threads:
https://bbs.archlinux.org/viewtopic.php?id=132931
https://bbs.archlinux.org/viewtopic.php?id=142006
https://bbs.archlinux.org/viewtopic.php?pid=1107433
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Thursday, 14 June 2012, 05:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.4.2-1
Comment by Roberto Catini (robcat) - Thursday, 31 May 2012, 00:24 GMT
After some time on my system using systemd and networkmanager, I can say one of the these scenarios presents at boot:
- the connection does not start with the authentication time out as reported earlier
- the connection works for about an hour, then is dropped without a specific reason
Comment by Roberto Catini (robcat) - Wednesday, 13 June 2012, 22:31 GMT
I've installed the 3.4.2 kernel and the buggy behavior is disappeared.
Booting with all the default modules options there haven't been problems for many hours of uptime and several reboots.

Current dmesg log (success at first try):

$ dmesg |grep wlan0
[ 10.705021] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 13.998938] wlan0: authenticate with 00:24:89:43:b1:cf
[ 14.018973] wlan0: send auth to 00:24:89:43:b1:cf (try 1/3)
[ 14.020670] wlan0: authenticated
[ 14.031704] wlan0: associate with 00:24:89:43:b1:cf (try 1/3)
[ 14.034039] wlan0: RX AssocResp from 00:24:89:43:b1:cf (capab=0x401 status=0 aid=1)
[ 14.034053] wlan0: associated
[ 14.034442] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 24.892756] wlan0: no IPv6 routers present

Loading...