Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30034 - [audacious-3.2.3-1] mime-type inode/directory render nautilus unusable

Attached to Project: Community Packages
Opened by solsTiCe (zebul666) - Sunday, 27 May 2012, 09:15 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Saturday, 30 November 2013, 18:28 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

I know you could describe this has an upstream bug but this is a MAJOR annoyance.

Since latest update of audacious, one can't use nautilus in gnome (3 fallback mode), because it simply launches audacious which has mime/type associated with inode/directory.

So I can't browse files if I click one Home folder or whatever because it luacnhes audacious instead of nautilus.
This task depends upon

Closed by  BartÅ‚omiej Piotrowski (Barthalion)
Saturday, 30 November 2013, 18:28 GMT
Reason for closing:  Not a bug
Comment by solsTiCe (zebul666) - Tuesday, 29 May 2012, 12:34 GMT
the fix is to remove inode/directory from the MimeType line in the .dsktop file
Comment by John Lindgren (jlindgren) - Tuesday, 29 May 2012, 21:52 GMT
The fix is to change your default application for opening directories. "inode/directory" in the .desktop file means that Audacious can handle directories on its command line, not that it should be picked as the default application to open them.
Comment by Gaetan Bisson (vesath) - Tuesday, 29 May 2012, 22:44 GMT
I concur with John. See for instance:
- http://standards.freedesktop.org/desktop-entry-spec/latest/
- http://library.gnome.org/admin/system-admin-guide/stable/mimetypes-registering.html.en

Please create a bug report for GNOME/Nautilus: it should not default to calling an external application to open directories...
Comment by Jonas Abrahamsson (JKAbrams) - Saturday, 30 November 2013, 18:27 GMT
  • Field changed: Percent Complete (100% → 0%)
The same error occurs on KDE with Dolphin as file manager.
Adding the .desktop file might be the right thing to do according to the specification, but right neither Gnome or KDE appears to do this, and so Audacious breaks them... (Or is it perhaps a just a Gnome as Firefox is GTK?)
Sorry for ths re-open request, I don't seem to be able to comment on closed bugs, or I just cant find the comment button...

Loading...