Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30021 - [cups] cannot print pdfs with cups 1.5.3-2 : /usr/lib/cups/filter/pdftops failed

Attached to Project: Arch Linux
Opened by Frederic Bezies (fredbezies) - Saturday, 26 May 2012, 07:33 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 29 May 2012, 14:41 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description: Since upgrade to version 1.5.3-2, my epson stylus sx 218 cannot print. I got this in my cups http interface :

/usr/lib/cups/filter/pdftops failed

Additional info:
- cups 1.5.3-2

Steps to reproduce:

Just try to print a pdf file with cups 1.5.2. And then, open cups web interface and look at pending tasks.

Tried with mozilla firefox or evince without any luck :(
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 29 May 2012, 14:41 GMT
Reason for closing:  Fixed
Comment by Frederic Bezies (fredbezies) - Saturday, 26 May 2012, 07:34 GMT
Looks like to be a cups-filter bug, but it break some cups features, so...

Comment by Andreas Radke (AndyRTR) - Saturday, 26 May 2012, 09:40 GMT
Remove cups-filter pkg. It's not needed together with cups 1.5.x and breaks some stuff.
Comment by Frederic Bezies (fredbezies) - Saturday, 26 May 2012, 14:31 GMT
Well, after I verified, I do not have cups-filters installed. Only cups and libcups, both in version 1.5.3-2.

Edit : pdf printing works after I installed cups-filters... Something is broken in cups or what ? And if I want to remove libusb-compat, about 1 Gb of software is going to be removed... So something is broken with libusb change, which is the main change of cups 1.5.3-2.
Comment by Andreas Radke (AndyRTR) - Saturday, 26 May 2012, 22:01 GMT
Are you using plain cups or some additional driver pkg like hplip or splix?

Maybe removed libusb-compat dep is now needed somewhere else that was covered before. For reference look at Fedora/Debian/Gentoo packages.
Comment by Mike Sampson (mikesd) - Saturday, 26 May 2012, 23:56 GMT
I'm getting the same error printing to a Kyocera Networked PS printer. Tried rolling cups and libcups back as far as 1.5.2-2 without luck.
Comment by Jim Niz (linkmaster03) - Sunday, 27 May 2012, 01:46 GMT
I am also receiving this error, printing with the "HP Photosmart c6200 Series, hpcups 3.10.6" driver, cups 1.5.3-2, cups-filters not installed. However, I was able to use pdftops in terminal to manually generate a PostScript file from my PDF. Then, I used lpr to successfully print the document. It's worth a try if you need to print something while this issue is resolved.
Comment by Frederic Bezies (fredbezies) - Sunday, 27 May 2012, 05:04 GMT
@Andreas : I'm using this AUR package in order to get my printer working : http://aur.archlinux.org/packages.php?ID=47182

The only workaround for me was to force the installation - I know it is very dirty to do this - of cups filter. The pdftops executable of cups package won't work. Only the one in cups-filters works. Weird :(
Comment by Babets (Babets) - Sunday, 27 May 2012, 13:38 GMT
I have this issue using hplip with a hp laserjet printer connected on my router.
If this could be useful I got this on dmesg every time I try to print:

[ 328.083103] pdftops[1342] trap divide error ip:7fafd54bcdf4 sp:7fffa94d8410 error:0 in libpoppler.so.25.0.0[7fafd536b000+211000]
[ 1018.283971] pdftops[1574] trap divide error ip:7fef98f6adf4 sp:7fffb6b74100 error:0 in libpoppler.so.25.0.0[7fef98e19000+211000]

The cups web interface show "pdftops failed" as said by fredbezies.
I don't know if it's related but my printer also said that the ink level is low and it's strange because I printed days ago and the ink level was 100%.
Comment by Douglas McFadzean (ninian) - Sunday, 27 May 2012, 15:49 GMT
Same problem with a networked HP LaserJet 2100 printer, using the driver: HP LaserJet 2100 hpijs, 3.11.12 (color, 2-sided printing)
Packages being used: cups 1.5.3-2, cups-pdf 2.6.1-1, libcups 1.5.3-2, libgnomecups 0.2.3-9, hplip 3.12.4-1
Comment by Marc Harter (wavded) - Monday, 28 May 2012, 00:09 GMT
Same problem for me too with Brother LaserJet HL-2140.
Comment by Marc Harter (wavded) - Monday, 28 May 2012, 00:21 GMT
Not sure if this will help but I noticed that printing does work sometimes. For example, I had an email in my Gmail Inbox that would not print even though I restarted the machine, reset the printer, reupdated the drivers. But when I removed an <img> element from the email, it printed. I noticed a couple PDF's I had, one with some images stripped out worked, but the one with images didn't.
Comment by Adrian Benson (abenson) - Monday, 28 May 2012, 03:08 GMT
There was a version update for poppler on 26 May - I suspect this is an issue with poppler rather than cups.
pdftops is part of poppler
Comment by ozar (ozar) - Monday, 28 May 2012, 03:46 GMT
Yes, downgrading poppler, poppler-glib, and poppler-qt to version 0.18.4-2 fixed the printer issue for me. Not sure which of those files actually fixed it though.
Comment by Adrian Benson (abenson) - Monday, 28 May 2012, 05:07 GMT
Running 'pdftops' directly on a file that borked my printer via cups produces flawless postscript.

So I just downloaded and built the latest cups-filters http://www.openprinting.org/download/cups-filters/cups-filters-1.0-20120528.tar.gz. Did a force install to overwrite the filters that come with cups. Everything works now.

There must be an incompatibility between the default cups-1.5.3 filter files and the latest poppler.
Comment by Mike Sampson (mikesd) - Monday, 28 May 2012, 06:58 GMT
Downgrading poppler and poppler-glib to version 0.18.4-2 fixed it for me. Similar to ozar above.
Comment by Andreas Radke (AndyRTR) - Monday, 28 May 2012, 09:31 GMT
Does recompiliung cups against new poppler help?
Comment by Andreas Radke (AndyRTR) - Monday, 28 May 2012, 16:53 GMT
Please test cups 1.5.3-3 in testing.

We now use the new cups-filter pkg replacing parts of cups that will be dropped in 1.6 - Debian does the same now for some timer in Sid also with cups 1.5.x.
Comment by ozar (ozar) - Monday, 28 May 2012, 17:44 GMT
Andreas... yes, the 1.5.3-3 CUPS release in testing works well for me, and it does so with the latest release of poppler.

Thank you.
Comment by Mike Sampson (mikesd) - Monday, 28 May 2012, 22:11 GMT
Yes that works fine now for me too. Latest cups and poppler.

I also noticed cups-filters was installed as a dependency. This is the first time I have had this package installed. I did try to install it earlier to solve this issue however it gave a conflict error so I left it.

Thanks Andreas.
Comment by Douglas McFadzean (ninian) - Monday, 28 May 2012, 22:16 GMT
Works for me too, with fully updated system plus cups 1.5.3-3 and libcups 1.5.3-3 from testing.
However, I had to change the driver to HP LaserJet 2100, hpcups 3.12.4 to get things printing off properly (previously used HP LaserJet 2100 hpijs, 3.11.12).

Loading...