Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29998 - [pinentry] pinentry-qt4 breaks Alt+Tab window switching in KDE

Attached to Project: Arch Linux
Opened by Maciej Sitarz (macieks2) - Thursday, 24 May 2012, 08:50 GMT
Last edited by Tobias Powalowski (tpowa) - Friday, 25 May 2012, 12:43 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I'm having problems with pinentry-qt4. After each usage/password entered
Alt+Tab in KDE can't switch windows, "No windows" shows instead. After
that I need to switch to another window by selecting it on Task manager bar.


Additional info:
* package versions:
pinentry 0.8.1-3
kdebase-lib 4.8.3-1

Steps to reproduce:
1. Check Alt+Tab window list (there should be few)
2. Run in konsole: echo GETPIN | pinentry-qt4
3. Type whatever you like press 'Enter'
4. Press 'Alt+Tab' to check window list. Instead of current window list
"No windows" info appears.

It looks like Fedora has it fixed with a patch[1] they apply on their RPM. I recompiled the package with the patch applied and it looks like it's working fine.

I already reported that problem to gnupgp mailing list[2], but with no confirmation on the solution proposed. That's why I suggest to include the patch in Arch's package, instead of waiting for upstream fix.

[1] http://pkgs.fedoraproject.org/gitweb/?p=pinentry.git;a=blob_plain;f=0001-Fix-qt4-pinentry-window-created-in-the-background.patch;hb=HEAD
[2] http://lists.gnupg.org/pipermail/gnupg-devel/2012-May/026704.html
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Friday, 25 May 2012, 12:43 GMT
Reason for closing:  Fixed
Additional comments about closing:  0.8.1-4
Comment by Andrea Scarpino (BaSh) - Thursday, 24 May 2012, 12:25 GMT
Which qt version did you try?

EDIT: I read you tried with 4.8.1, please test 4.8.2 too.
Comment by Maciej Sitarz (macieks2) - Friday, 25 May 2012, 12:05 GMT
Same situation with qt 4.8.2.
Comment by Andrea Scarpino (BaSh) - Friday, 25 May 2012, 12:35 GMT
Tobias the patch has to be applied to the pinetry package, not qt

Loading...