Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29988 - [wireshark-cli] install script failed to execute correctly

Attached to Project: Arch Linux
Opened by vicencb (vicencb) - Wednesday, 23 May 2012, 18:29 GMT
Last edited by Jan de Groot (JGC) - Thursday, 31 May 2012, 13:52 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Guillaume ALAUX (galaux)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

When upgrading wireshark-cli the following error is reported:
(4/5) upgrading wireshark-cli [######################] 100%
Failed to set capabilities on file `usr/bin/dumpcap' (Operation not supported)
usage: setcap [-q] [-v] (-r|-|<caps>) <filename> [ ... (-r|-|<capsN>) <filenameN> ]

Note <filename> must be a regular (non-symlink) file.
error: command failed to execute correctly


Additional info:
* package version(s)
wireshark-cli: 1.6.8-1
libcap: 2.22-3
pacman: 4.0.3-1
* config and/or log files etc.


Steps to reproduce:
as root: pacman -Syu
This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 31 May 2012, 13:52 GMT
Reason for closing:  Not a bug
Additional comments about closing:  User configuration issue. Default kernel works.
Comment by Ionut Biru (wonder) - Wednesday, 23 May 2012, 18:45 GMT
works for me. something is wrong in your system.

ls -l /usr/bin/dumpcap
-rwxr-xr-- 1 root wireshark 63424 May 22 22:23 /usr/bin/dumpcap

as you can see, the file is NOT a symlink.
Comment by vicencb (vicencb) - Wednesday, 23 May 2012, 18:58 GMT
I've checked this also and is not a symlink neither in my case.
Does strace provide more information?
strace -o strace setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' /usr/bin/dumpcap
Can this problem be caused by a custom kernel?

Thanks
   strace (5.1 KiB)
Comment by Ionut Biru (wonder) - Wednesday, 23 May 2012, 19:07 GMT
what file system is on / ?
Comment by vicencb (vicencb) - Wednesday, 23 May 2012, 19:10 GMT
/dev/root on / type ext4 (rw,relatime,data=ordered)
Comment by Jason William Walton (jasonww) - Wednesday, 30 May 2012, 21:21 GMT
Enable CONFIG_EXT4_FS_SECURITY if you want this to work.
Comment by vicencb (vicencb) - Wednesday, 30 May 2012, 22:20 GMT
In fact this config option and CONFIG_EXT4_FS_XATTR which is a dependency are not set.
My fault.
Thanks for your attention.

Loading...