Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29970 - [xfwm4] Random Window Move on Mouse Select or Click

Attached to Project: Arch Linux
Opened by TuX (TuxLyn) - Tuesday, 22 May 2012, 04:26 GMT
Last edited by Evangelos Foutras (foutrelis) - Thursday, 19 July 2012, 20:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: I get some sort of bug with my XFCE 4.10 now that some windows would move randomly when I ether click or select some text in any of the software. This is very weird bug, I never had this issue in XFCE 4.8 before. This started to happen when I've installed XFCE 4.10. I've even installed everything fresh, and bought a new mouse. Still same issue.

Steps to reproduce: This can't be reproduced always, this happends randomly. Maybe some one else have this issue too, please explain in comments.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Thursday, 19 July 2012, 20:34 GMT
Reason for closing:  Fixed
Additional comments about closing:  xfwm4 4.10.0-2
Comment by Evangelos Foutras (foutrelis) - Wednesday, 23 May 2012, 16:23 GMT
I've seen this happen with Rhythmbox, but it occurs rarely.

We'll have to find a way to reproduce the issue on demand, in order to report it upstream.
Comment by TuX (TuxLyn) - Thursday, 24 May 2012, 05:13 GMT
Yeah well I don't use rhythmbox, I do use gedit and this happend to it a lot. So the issues might be in XFCE or XServer it self.
Comment by Evangelos Foutras (foutrelis) - Thursday, 19 July 2012, 16:30 GMT
I believe this is the upstream report for this issue:

https://bugzilla.xfce.org/show_bug.cgi?id=8949

I have applied the patch in xfwm4 4.10.0-2; can you please confirm that the issue is fixed for you as well?
Comment by Thomas (radioactiveman) - Thursday, 19 July 2012, 17:13 GMT
I'm the upstream reporter and can confirm that the patch is resolving this annoying issue.

Loading...