Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29953 - [ortp] [linphone] doesn't start

Attached to Project: Community Packages
Opened by Xavion (Xavion) - Sunday, 20 May 2012, 05:06 GMT
Last edited by Andrea Scarpino (BaSh) - Monday, 19 November 2012, 21:16 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Andrea Scarpino (BaSh)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

After upgrading my system packages yesterday, I can no longer use the Linphone application. I've tried to rebuild the package, but an error is preventing me from doing so. I've attached both outputs to this ticket; let me know if you need more information.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Monday, 19 November 2012, 21:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  seems fixed
Comment by Andrea Scarpino (BaSh) - Sunday, 20 May 2012, 08:48 GMT
This is due to libzrtpcpp support in ortp ( FS#29846 ).
I found this http://osdir.com/ml/linphone-users/2012-02/msg00065.html ,maybe we should switch to the 2.1.2 or 2.2.0 from git? https://github.com/wernerd/ZRTPCPP/tags
Sergej probably knows more about this than me.
Comment by Sergej Pupykin (sergej) - Sunday, 20 May 2012, 10:28 GMT
@Andrea, yes, I built 2.1.2 from github and it looks ok. Please updated it and I'll rebuild linphone then.

It is enough just replace source url, libzrtpcpp-2.1.2 builds well.
Comment by Andrea Scarpino (BaSh) - Monday, 21 May 2012, 09:44 GMT
Done, I just uploaded libzrtpcpp 2.1.2 to [extra]
Comment by Xavion (Xavion) - Tuesday, 22 May 2012, 09:23 GMT
  • Field changed: Percent Complete (100% → 0%)
I upgraded 'libzrtpcpp' to v2.1.2-1 and 'linphone' to v3.5.2-4 and the latter still won't run. Rebuilding Linphone didn't fix the problem either, although at least it builds successfully now. For your reference, I've attached the new output I get when running Linphone.
Comment by Sergej Pupykin (sergej) - Tuesday, 22 May 2012, 09:26 GMT
I can start linphone. May be you should try to erase .linphonerc?
Comment by Jukka (jukkak) - Tuesday, 22 May 2012, 11:44 GMT
I have the same problem with the same symptoms (=log) as Xavion even after erasing .linphonerc !
Comment by Xavion (Xavion) - Tuesday, 22 May 2012, 21:25 GMT
Erasing my ".linphonerc" file before launching Linphone didn't fix the problem. Are you sure that I only needed to upgrade the 'libzrtpcpp' and 'linphone' packages?
Comment by Sergej Pupykin (sergej) - Wednesday, 23 May 2012, 06:29 GMT
Probably you should upgrade whole system with -Syu. It is the single way of arch upgrading.
Comment by Xavion (Xavion) - Friday, 25 May 2012, 23:05 GMT
I've been running Arch Linux for several years, so I've used "-Suy" more than a few times. In this case, upgrading all system packages didn't fix the problem. I'm still getting the same output that I attached to my May 22 comment. Do you guys have any other suggestions, or should I just email the author?
Comment by Sergej Pupykin (sergej) - Saturday, 26 May 2012, 18:30 GMT
I have no ideas, I think advise from upstream would be helpfull.
Comment by Xavion (Xavion) - Sunday, 27 May 2012, 21:08 GMT
I have requested advice from the Linphone mailing list about this problem. The thread can be viewed here: http://lists.nongnu.org/archive/html/linphone-users/2012-05/msg00056.html
Comment by Xavion (Xavion) - Thursday, 31 May 2012, 23:43 GMT
It appears that this problem is also occurring on Fedora Linux. A backtrace is attached to this bug report: https://bugzilla.redhat.com/show_bug.cgi?id=824267
Comment by Xavion (Xavion) - Friday, 01 June 2012, 00:40 GMT
Okay, I've figured out what needs to be done. The 'ortp' package in 'extra' must also be upgraded to the Git version. You guys possibly already did this on your systems and then forgot about it. Using the "ortp-git" package from AUR makes Linphone work again!
Comment by Sergej Pupykin (sergej) - Friday, 01 June 2012, 08:29 GMT
Here is the diff between ortp and ortp-git. It can be compiled at least.

May be we should build ortp with it?
Comment by Dmitry (helicopter) - Friday, 01 June 2012, 16:06 GMT
I have the same problem, downgrading linphone to version 3.5.2-2 did not help.
   Run.txt (6.3 KiB)
Comment by Dmitry (helicopter) - Saturday, 02 June 2012, 10:55 GMT
i have compilled linphone with default configure options (see PKGBUILD), it starts sucessfully
   PKGBUILD (0.9 KiB)
Comment by Andrea Scarpino (BaSh) - Sunday, 01 July 2012, 07:45 GMT
Hi, I updated ortp to a current snapshot, can you confirm this fixes the linphone crash?
Comment by Alb (pzdmrd) - Saturday, 07 July 2012, 19:03 GMT
Hi Andrea, it doesnt fix the problem for me.
In order to have linphone working i've to use ortp-0.20.0-1
or recompile ortp without zrtp support.
Comment by Jason (einseenai) - Friday, 24 August 2012, 16:52 GMT
Having the same issue. Linphone actually worked right after installation. The issue probably started after reboot. Now installed ortp-git, didn't solve the problem. Then I removed it and installed ortp from repos. Linphone started. I'll see if it keeps that way after reboot.
Comment by Seth F. (srf21c) - Friday, 31 August 2012, 05:55 GMT
linphone Community Package crashed on launch for me too.

Quick n dirty workaround: install linphone-git from AUR.
Comment by Greg (dolby) - Monday, 19 November 2012, 08:04 GMT
Still a problem?

Loading...