Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29950 - [xscreensaver] - unneeded dependencies in PKGBUILD

Attached to Project: Arch Linux
Opened by John (graysky) - Saturday, 19 May 2012, 18:17 GMT
Last edited by Eric Belanger (Snowman) - Tuesday, 22 May 2012, 18:52 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Per namcap, the PKGBULD contains unneeded deps.

xscreensaver E: Missing custom license directory (usr/share/licenses/xscreensaver-arch-logo)
xscreensaver W: Dependency pam included but already satisfied
xscreensaver W: Dependency included and not needed ('xorg-appres')
xscreensaver W: Dependency included and not needed ('perl-libwww')
xscreensaver W: Dependency included and not needed ('perl-http-message')

Also, why is gdm listed as a makedep? Package builds fine without it.

Additional info:
* package version(s) 5.15-3
This task depends upon

Closed by  Eric Belanger (Snowman)
Tuesday, 22 May 2012, 18:52 GMT
Reason for closing:  Not a bug
Comment by Dave Reisner (falconindy) - Saturday, 19 May 2012, 21:05 GMT
As it turns out, there's perl scripts included with xscreensaver and one of them calls appres, so those dependencies are correct (they could be optdeps if you wanted to be pedantic). gdm probably isn't a legit makedep looking at the configure file, but was added because of a bug report that you (graysky) opened.

namcap is an advisory tool. Please actually look into the warnings it emits before filing bug reports.
Comment by John (graysky) - Sunday, 20 May 2012, 13:10 GMT
Ah, I remember now. https://bugs.archlinux.org/task/25617 is the bug report to which you refer. Guess it's only relevant if users:

1) Use gdm and
2) want to compile using the --with-login-manager switch

Thank you for the reminder. I've been happily using lxdm ever since the wife got a macbook and I have no need to user switch :)

Requesting closure, sorry for the trouble.

Loading...