Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29930 - [lyx] 2.0.3-3 failst to start: libicuuc.so.48: cannot open shared object file

Attached to Project: Arch Linux
Opened by Jakub Pastuszek (jpastuszek) - Thursday, 17 May 2012, 12:13 GMT
Last edited by Eric Belanger (Snowman) - Friday, 18 May 2012, 16:02 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Lyx fails to start due to unmet dynamic library dependency.

# lyx
lyx: error while loading shared libraries: libicuuc.so.48: cannot open shared object file: No such file or directory

Latest verion of icu is 49 while lyx is linked against 48:
# pacman -S icu
warning: icu-49.1.1-1 is up to date -- reinstalling

# ls /usr/lib/libicuuc.so*
/usr/lib/libicuuc.so /usr/lib/libicuuc.so.49 /usr/lib/libicuuc.so.49.1.1

# ldd /usr/bin/lyx | grep 'not found'
libicuuc.so.48 => not found
libicui18n.so.48 => not found
libicudata.so.48 => not found

Additional info:

* package version
lyx-2.0.3-3
icu-49.1.1-1

Steps to reproduce:

1. Install lyx with:
# pacman -S lyx
2. Try to start lyx from console:
# lyx
This task depends upon

Closed by  Eric Belanger (Snowman)
Friday, 18 May 2012, 16:02 GMT
Reason for closing:  Not a bug
Comment by Eric Belanger (Snowman) - Thursday, 17 May 2012, 12:52 GMT
Lyx starts fine here. It doesn't even link to icu:
$ readelf -d /usr/bin/lyx

Dynamic section at offset 0x859d60 contains 35 entries:
Tag Type Name/Value
0x0000000000000001 (NEEDED) Shared library: [libboost_regex.so.1.49.0]
0x0000000000000001 (NEEDED) Shared library: [libboost_signals.so.1.49.0]
0x0000000000000001 (NEEDED) Shared library: [libmythes-1.2.so.0]
0x0000000000000001 (NEEDED) Shared library: [libenchant.so.1]
0x0000000000000001 (NEEDED) Shared library: [libhunspell-1.3.so.0]
0x0000000000000001 (NEEDED) Shared library: [libaspell.so.15]
0x0000000000000001 (NEEDED) Shared library: [libz.so.1]
0x0000000000000001 (NEEDED) Shared library: [libQtGui.so.4]
0x0000000000000001 (NEEDED) Shared library: [libQtCore.so.4]
0x0000000000000001 (NEEDED) Shared library: [libstdc++.so.6]
0x0000000000000001 (NEEDED) Shared library: [libm.so.6]
0x0000000000000001 (NEEDED) Shared library: [libgcc_s.so.1]
0x0000000000000001 (NEEDED) Shared library: [libpthread.so.0]
0x0000000000000001 (NEEDED) Shared library: [libc.so.6]

Make sure your system is up-to-date. And that you don't have any old custom packages that still links to the old icu.
Comment by Jakub Pastuszek (jpastuszek) - Friday, 18 May 2012, 13:25 GMT
Thanks for the readelf -d command.
With that I have found out that libboost_regex is pulling libicuuc.so.48.

After I have updated boost-libs to latest version (1.49.0-2) the issue is resolved!

Sorry for trouble,
Thanks!
Comment by Eric Belanger (Snowman) - Friday, 18 May 2012, 15:59 GMT
You should fully update your system (pacman -Syu) if you haven't done so, otherwise you might run into similar problems.

Loading...