Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29921 - [Netcf] patch to build against libnl-3 breaks libvirt

Attached to Project: Community Packages
Opened by mutantmonkey (MutantMonkey) - Thursday, 17 May 2012, 03:54 GMT
Last edited by Sergej Pupykin (sergej) - Thursday, 17 May 2012, 10:30 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
The patch to link netcf against libnl-3 from  FS#29908  prevents libvirt from starting with the following message:
BUG: route/tc.c:970
libvirtd: route/tc.c:970: rtnl_tc_register: Assertion `0' failed.
/etc/rc.d/libvirtd: line 14: 1575 Aborted KRB5_KTNAME=$KRB5_KTNAME /usr/sbin/libvirtd --daemon $LIBVIRTD_CONFIG_ARGS $LIBVIRTD_ARGS

Downgrading to netcf 0.1.9-1 solves the problem.

Additional info:
* libvirt 0.9.11-7
* netcf 0.1.9-2

Steps to reproduce:
* Install netcf 0.1.9-2 and libvirt
* Try to start libvirtd
This task depends upon

Closed by  Sergej Pupykin (sergej)
Thursday, 17 May 2012, 10:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  Probably fixed with  FS#29891 
Comment by Evaggelos Balaskas (ebal) - Thursday, 17 May 2012, 06:26 GMT
Confirmed, same here

downgraded to netcf-0.1.7-3
Comment by Sergej Pupykin (sergej) - Thursday, 17 May 2012, 09:48 GMT
please try libvirt-0.9.12-3 and netcf-0.1.9-2

Loading...