Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29875 - [amule] 10785-1 crash when shows statistics

Attached to Project: Arch Linux
Opened by Carlos (cyberconan) - Sunday, 13 May 2012, 18:03 GMT
Last edited by Giovanni Scafora (giovanni) - Thursday, 17 May 2012, 06:47 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Giovanni Scafora (giovanni)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Crash.

Additional info:
package version: 10785-1
config and/or log files etc.

--------------------------------------------------------------------------------
A fatal error has occurred and aMule has crashed.
Please assist us in fixing this problem by posting the backtrace below in our
'aMule Crashes' forum and include as much information as possible regarding the
circumstances of this crash. The forum is located here:
http://forum.amule.org/index.php?board=67.0
If possible, please try to generate a real backtrace of this crash:
http://wiki.amule.org/index.php/Backtraces

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule SVN compiled with wxGTK2 v2.8.12 (Snapshot: rev. 10785)
Running on: Linux 3.0.31-1-lts x86_64

[2] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.8.so.0[0x7f726011acbc]
[3] ?? in /lib/libpthread.so.0[0x7f7261dcc140]
[4] ?? in amule[0x5954e9]
[5] ?? in amule[0x5932d8]
[6] ?? in amule[0x5933e3]
[7] ?? in amule[0x5934fe]
[8] ?? in amule[0x58efe4]
[9] ?? in amule[0x535167]
[10] ?? in amule[0x508bcc]
[11] wxEvtHandler::ProcessEventIfMatches(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&) in /usr/lib/libwx_baseu-2.8.so.0[0x7f7260117a25]
[12] wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*) in /usr/lib/libwx_baseu-2.8.so.0[0x7f7260117b8c]
[13] wxEvtHandler::ProcessEvent(wxEvent&) in /usr/lib/libwx_baseu-2.8.so.0[0x7f7260117ec4]
[14] wxTimerBase::Notify() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x7f7260870119]
[15] ?? in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x7f726079fc8b]
[16] ?? in /usr/lib/libglib-2.0.so.0[0x7f725e04d04b]
[17] g_main_context_dispatch in /usr/lib/libglib-2.0.so.0[0x7f725e04c4b5]
[18] ?? in /usr/lib/libglib-2.0.so.0[0x7f725e04c7e8]
[19] g_main_loop_run in /usr/lib/libglib-2.0.so.0[0x7f725e04cbe2]
[20] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0x7f725eb4fb87]
[21] wxEventLoop::Run() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x7f7260798228]
[22] wxAppBase::MainLoop() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x7f726080784b]
[23] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.8.so.0[0x7f72600c880b]
[24] ?? in amule[0x44b5d2]
[25] __libc_start_main in /lib/libc.so.6[0x7f725f274455]
[26] ?? in amule[0x457745]

--------------------------------------------------------------------------------
Abortado

Steps to reproduce: Launch amule, click in statistics icon and wait a few seconds.

This task depends upon

Closed by  Giovanni Scafora (giovanni)
Thursday, 17 May 2012, 06:47 GMT
Reason for closing:  Fixed
Comment by Giovanni Scafora (giovanni) - Monday, 14 May 2012, 18:45 GMT
I cannot reproduce it on my local machine and amule doesn't crash when shows statistics.
I'm using x86_64 with wxgtk 2.8.12.1-3
Running on: Linux 3.3.5-1-ARCH
Please, try updating your system.
Comment by Carlos (cyberconan) - Monday, 14 May 2012, 19:23 GMT
Maybe the problem is only with LTS kernel. I'll try reboot and use the 3.3.6 version.
Comment by Giovanni Scafora (giovanni) - Monday, 14 May 2012, 19:39 GMT
OK, please let me know.
Comment by Carlos (cyberconan) - Monday, 14 May 2012, 20:22 GMT
Problem persist. I tried remove gtk2-ubuntu from Aur and install oficial gtk2 and nothing. Remove .aMule from my home directory and nothing, too. Only when downgroading to amule-10771-1, statistics works again and amule no crash.
Comment by Giovanni Scafora (giovanni) - Tuesday, 15 May 2012, 10:28 GMT
I really don't know how I can help you as I cannot reproduce that issue on my local machine.
Comment by Carlos (cyberconan) - Wednesday, 16 May 2012, 23:43 GMT
I remove some apearance AUR packages and now amule works well again. The bug can be closed. Thanks Giovanni.
Comment by Giovanni Scafora (giovanni) - Thursday, 17 May 2012, 06:46 GMT
amule-10788 fix crash in the statistics window.

Loading...