Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers

FS#29859 - Daily ISO Snapshots Bug

Attached to Project: Release Engineering
Opened by TuX (TuxLyn) - Saturday, 12 May 2012, 20:43 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Monday, 26 November 2012, 04:54 GMT
Task Type Bug Report
Category AIF
Status Closed
Assigned To Dieter Plaetinck (Dieter_be)
Architecture All
Severity High
Priority Normal
Reported Version testbuild (specify!)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 15
Private No


Description: Daily ISO snapshots from has a weird bug when trying to set hard drive mount points.

Steps to reproduce:
1. Download latest snapshot iso and burn it on cd or boot from usb, any core iso will do (net-install has not been tested).

2. Select this options from main menu.

4. Prepare hard drive(s)
then select
3. Manually Configure block devices, filesystems and mountpoints
(click no if needed to start from scratch)
then select "uuid" option (but any will work)
ones you get to the "Manage filesystems" window,
you should see that every hard drive and partition is shown twice.

not only that, its not working when you trying to select any of them to configure. It looks like its configured but then in the main window nothing shown.

So its not possible to install arch from snapshots at this point at all.
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Monday, 26 November 2012, 04:54 GMT
Reason for closing:  Deferred
Comment by Jens Adam (byte) - Sunday, 13 May 2012, 16:05 GMT
Further info:
- you're still able to install if you take care of partitions, file systems and mount points (/mnt) manually, outside of the installer
- the "automatic" setup works!
- regression must have sneaked in somewhere in the 2nd half of April, but don't take my word on it
Comment by Jens Adam (byte) - Sunday, 13 May 2012, 17:38 GMT
.. and now, being in the right category, I can see at least 3 or 4 similar reports, like  FS#29525 
Comment by TuX (TuxLyn) - Sunday, 13 May 2012, 18:24 GMT
@ Jens Adam, I don't use automatic installs.
Comment by TuX (TuxLyn) - Sunday, 13 May 2012, 18:26 GMT
Yeah this is what I have simular to it like this screenshot > and bug
Comment by Frederic Bezies (fredbezies) - Tuesday, 15 May 2012, 07:24 GMT
Seeing it too in my grub bug report #29816

Partitions listed twice, grub is lost and cannot install anything :(
Comment by Thomas Hebb (tchebb) - Sunday, 20 May 2012, 00:06 GMT Comment by Bernhard Dunkl (bernhard_dunkl) - Wednesday, 13 June 2012, 18:52 GMT
I've successfully installed arch linux two times using the snapshot "archlinux-2012.06.05_04-00-01-netinstall-x86_64.iso" and the patch from Thomas Hebb. The first installation was with root on a single md raid0 device and no additional partitions (no boot, no swap). The second installation was with root on a luks partition and a seperate boot partition (no swap). I partitioned my harddisks with gdisk prior to the installation. During installation I chose "Manually configure block devices, filesystems and mountpoints" and everything worked as expected, partitions were not listed twice.
Comment by Kailean Courtney (courtnek) - Thursday, 21 June 2012, 22:50 GMT
Bernhard, would you mind sharing how to correct the latest snapshot with the patch? The patch looks to point to a aif git repo, but I do not know how to build that into the archiso tree...
Comment by Bernhard Dunkl (bernhard_dunkl) - Friday, 22 June 2012, 07:14 GMT
Kailean, I booted the snapshot image and corrected the affected file (/usr/lib/aif/core/libs/ by hand in the live environment. I used the patch, which Thomas had posted on the mailing list (see his comment above from Sunday, 20 May). Keep in mind that the way I've applied the patch doesn't make it permanent on the install image.