Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29842 - [squid] ABS build is broken with --disable-internal-dns option

Attached to Project: Arch Linux
Opened by Paul Gideon Dann (giddie) - Friday, 11 May 2012, 11:52 GMT
Last edited by Dave Reisner (falconindy) - Saturday, 09 June 2012, 20:03 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When building Squid 3.1.19-2 from ABS, and adding the --disable-internal-dns option to the configure line, building fails at the linking stage with the following output:

libtool: link: g++ -Wall -Wpointer-arith -Wwrite-strings -Wcomments -Werror -D_REENTRANT -m64 -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -m64 -Wl,-O1 -Wl,--sort-common -Wl,--as-needed -Wl,-z -Wl,relro -Wl,--hash-style=gnu -o dnsserver dnsserver.o
dnsserver.o: In function `operator delete(void*)':
dnsserver.cc:(.text._ZdlPv[_ZdlPv]+0x5): undefined reference to `xfree'
collect2: error: ld returned 1 exit status
make[3]: *** [dnsserver] Error 1

As far as I can make out, xfree should be provided by libiberty. I tried adding -liberty to the line, but it had no effect. I suspect this is upstream bitrot, but I thought it worth raising here in case someone knew of a simply fix.
This task depends upon

Closed by  Dave Reisner (falconindy)
Saturday, 09 June 2012, 20:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  squid-3.1.20
Comment by Jan de Groot (JGC) - Sunday, 13 May 2012, 14:45 GMT
You should contact upstream about this. The PKGBUILD works fine as-is, your modification triggers an upstream bug that is not valid in our prebuilt package.
Comment by Paul Gideon Dann (giddie) - Monday, 14 May 2012, 10:14 GMT Comment by Dave Reisner (falconindy) - Friday, 08 June 2012, 23:26 GMT
This should be fixed with 3.1.20.
Comment by Paul Gideon Dann (giddie) - Saturday, 09 June 2012, 19:56 GMT
Thanks for the heads up; it's built and seems to be running as expected :)

Loading...