Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#29826 - [kdepim-ktimetracker] "Could not create the KTimeTracker part"

Attached to Project: Arch Linux
Opened by Oleg aka Blake-R (Blake-R) - Thursday, 10 May 2012, 05:53 GMT
Last edited by Andrea Scarpino (BaSh) - Wednesday, 05 September 2012, 14:08 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Andrea Scarpino (BaSh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



After start ktimetracker show dialog "Could not create the KTimeTracker part" and empty application window.

Console output:

$ ktimetracker
ktimetracker(20486)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
[Error dialog showns and OK button clicked]
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20 (X_GetProperty)
Resource id: 0x4e00024

Additional info:
* extra/kdepim-ktimetracker 4.8.3-1 (kde kdepim)
* Related KDE bug - as I understand it is need to rebuild package without compiler flags -Wl,-Bsymbolic-functions?

Steps to reproduce:
* Install kdepim-ktimetracker
* Run ktimetracker
* "Enjoy" of the error dialog and empty application window.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Wednesday, 05 September 2012, 14:08 GMT
Reason for closing:  Fixed
Additional comments about closing:  kdepim-ktimetracker 4.9.1-1
Comment by philippe (philou2424) - Friday, 11 May 2012, 20:16 GMT
(excuse my very bad english...)
I have the same problem and the same error message. It is since KDE's update.
I have kdepim-ktimetracker 4.8.3-1.
Comment by Javi (Gooler) - Tuesday, 12 June 2012, 08:11 GMT
Still present in 4.8.4-1
Comment by e85898 (metalzelot) - Saturday, 16 June 2012, 20:35 GMT
I have the same problem with the current version (4.8.4-1). With kdepim-ktimetracker 4.8.2-1 the bug does not yet exist.
Comment by Oleg aka Blake-R (Blake-R) - Tuesday, 07 August 2012, 04:52 GMT
Still present in 4.9.00
Comment by sergio (sergio) - Wednesday, 15 August 2012, 12:56 GMT Comment by Jairo Alonso Velásquez (JohnnyDeacon) - Monday, 27 August 2012, 01:40 GMT
Still present in kdepim-ktimetracker 4.9.0-3

Waiting for 4.9.1