Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers
Tasklist

FS#29816 - Grub installation is not possible with testing ISOs.

Attached to Project: Release Engineering
Opened by Frederic Bezies (fredbezies) - Wednesday, 09 May 2012, 15:57 GMT
Last edited by Dave Reisner (falconindy) - Sunday, 05 August 2012, 15:00 GMT
Task Type Bug Report
Category AIF
Status Closed
Assigned To Dieter Plaetinck (Dieter_be)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version testbuild (specify!)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

I tried since yesterday to install an archlinux in virtualbox with testing ISO from http://releng.archlinux.org/isos/

With 2012.05.09_04-00-01 (and previous ones), every single time I try to install grub, AIF cannot do it.

I noticed that all my partitions are listed twice.

Got an error dialog on grub install saying :

"Your root boot device could not be autodetected by setup. Ensure you adjust the 'root (hd0,0)' line in your GRUB config accordingly."

And after trying to install :

"Grub doesn't not know boot partition notation for . You will need to run manually run the GRUB shell to install a bootloader. And please, report this bug using the aif-report-issues script"

Logs : http://sprunge.us/AaZQ



This task depends upon

Closed by  Dave Reisner (falconindy)
Sunday, 05 August 2012, 15:00 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#29928 
Comment by Caio (caio.l) - Friday, 11 May 2012, 05:20 GMT
The same thing happen to me yesterday, when i tried to install ISO archlinux-2012.05.10_04-00-01-netinstall-x86_64.iso from VirtualBox.
Even tried Syslinux as a bootloader, but it failed too.
Comment by Alexandr Bezenkov (RealGecko) - Wednesday, 06 June 2012, 20:42 GMT
archlinux-2012.06.05_04-00-01-core-i686.iso tested with VirtualBox. Everything exactly the same as displayed on screenshots attached above.
Comment by Anonymous (reallybmn) - Friday, 08 June 2012, 15:11 GMT
Same for me !
archlinux-2012.06.05_04-00-01-core-dual.iso
using HDD auto partitionning
With virtualBox
Comment by mp (exzemat) - Monday, 18 June 2012, 04:25 GMT
Same here
archlinux-2012.06.05_04-00-01
archlinux-2012.05.10_04-00-01
netinstall and core x64
try on SSD
Comment by Evaryont (evaryont) - Wednesday, 11 July 2012, 06:20 GMT
I'm seeing the same issue as well.

Environment:
- VMWare Workstation 8
- archlinux-2012.06.05_04-00-01-core-x86_64
- 512MB RAM / 14GB HDD with automatic provisioning.

Pastebin, generated by aif-report-issues.sh: http://sprunge.us/AdVc
Comment by mp (exzemat) - Saturday, 14 July 2012, 11:12 GMT
I've resolved the problem installing with arboot.iso

Loading...