Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29786 - [grub-common] Build grub2-emu

Attached to Project: Arch Linux
Opened by Bruno Guerreiro (American_Jesus) - Sunday, 06 May 2012, 19:57 GMT
Last edited by Eli Schwartz (eschwartz) - Sunday, 05 August 2018, 21:14 GMT
Task Type Feature Request
Category Packages: Extra
Status Assigned   Reopened
Assigned To Ronald van Haren (pressh)
Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 3
Private No

Details

Description:
Build a separated package with --with-platform="emu" for development and debugging purposes.

Useful for developing themes, test new configurations
This task depends upon

Comment by Keshav Amburay (the.ridikulus.rat) - Sunday, 11 August 2013, 12:06 GMT
For anyone who requires this I modified the https://aur.archlinux.org/packages/grub-bzr/ PKGBUILD to include grub-emu support. Please try http://ix.io/7cE (all other source files remain same as in the AUR tar.gz file).
Comment by Keshav Amburay (the.ridikulus.rat) - Sunday, 11 August 2013, 12:10 GMT
I also don't think grub-emu is specifically required in grub pkg in the official repo. It is not used by everybody and it can be built from AUR if the user requires it.
Comment by Keshav Amburay (the.ridikulus.rat) - Wednesday, 14 August 2013, 05:52 GMT
My PKGBUILD has been incorporated by grub-bzr AUR maintainer into his PKGBUILD. I suppose this bug can be closed now.
Comment by Earnestly (Earnest) - Sunday, 05 August 2018, 21:13 GMT
  • Field changed: Percent Complete (100% → 0%)
The grub package doesn't appear to provide grub-emu at all even though the PKGBUILD seems to have code dedicated to doing so.
Comment by Eli Schwartz (eschwartz) - Sunday, 05 August 2018, 21:18 GMT
Closing this as "fixed" because an AUR package got it, makes no sense. Maybe if it was closed as "won't implement" I'd understand.

But then why does it *provide* something that is isn't actually packaged?
Also why include code to build it, then #ifdef (bash eqiv) the code out, if it will never ever be used?.
(This was only even added about a year after the feature request was closed as fixed...)
Comment by sf (callmejoe) - Friday, 17 April 2020, 02:47 GMT
trying to figure out how to get grub-emu. was there an AUR package at some time?
Comment by . (-_-) - Thursday, 11 February 2021, 18:54 GMT
commenting to remind the maintainers about this.

Loading...