Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29784 - keyboard, mouse and network broken with udev-182-2

Attached to Project: Arch Linux
Opened by André Silva (Emulatorman) - Sunday, 06 May 2012, 16:54 GMT
Last edited by Tom Gundersen (tomegun) - Monday, 07 May 2012, 15:42 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tom Gundersen (tomegun)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After update the system, keyboard, mouse and network doesn't work due udev new revision

Additional info:
* package version(s)
* config and/or log files etc.

udev-182-2

Steps to reproduce:

- update udev to 182-2.

I solved this problem downgrading to 182-1 via chroot from livecd.
   boot.log (2.2 KiB)
This task depends upon

Closed by  Tom Gundersen (tomegun)
Monday, 07 May 2012, 15:42 GMT
Reason for closing:  Not a bug
Comment by Tom Gundersen (tomegun) - Sunday, 06 May 2012, 18:59 GMT
Is your system fully up-to-date? In particular, do you have the most recent initscripts (without any local alterations)?

When udev-182-2 is installed, does it get started at boot? To find out, check "ps aux | grep udevd".
Comment by André Silva (Emulatorman) - Monday, 07 May 2012, 03:46 GMT
I'm using Parabola GNU/Linux-libre, and a lot of packages are from archlinux repo, eg: udev. So, on Parabola in this moment initscripts was updated (this package is on libre repo because is a branded version adapted for this distro) and it was resolved this problem with udev, thanks for the help :)
Comment by Tom Gundersen (tomegun) - Monday, 07 May 2012, 07:06 GMT
In the future please file bug reports with your own distribution.
Comment by Tom Gundersen (tomegun) - Monday, 07 May 2012, 09:43 GMT
@André: I just noticed that you are a Parabola hacker. If you guys notice problems with our packages, feel free to let us know, but please point out that you are not using the vanilla packages.

In general: if you are going to follow our package updates, it is important that you do not push your packages out-of-order. We generally don't use versioned dependencies, because we assume that users upgrade the packages in the order we publish them. If you don't, then things will break.
Comment by André Silva (Emulatorman) - Monday, 07 May 2012, 15:14 GMT
@tomegun: ah ok, thanks for the information.

Loading...