Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29752 - [midori/glib] Download dialog doesn't render

Attached to Project: Community Packages
Opened by Raphael Groner (k0Do) - Friday, 04 May 2012, 17:21 GMT
Last edited by Alexander F. Rødseth (xyproto) - Monday, 21 May 2012, 22:16 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Alexander F. Rødseth (xyproto)
Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
[from https://bugs.launchpad.net/midori/+bug/780133 ]
On some downloads, the download dialog which normally has buttons "Save" "Save As" "Open" and "Cancel" pops up but is an empty GTK window with no widgets inside.
Download dialog can still be used by clicking the buttons blind.

Maybe those provided patches help, not testd by myself.
glib > http://bugzilla-attachments.gnome.org/attachment.cgi?id=212002
midori > https://bugs.launchpad.net/midori/+bug/780133/+attachment/3117948/+files/workaround-glib-hangup-v3.patch


Additional info:
* package version(s)
midori 0.4.5-2
* config and/or log files etc.


Steps to reproduce:
Try to download some PDF or other binary content.
This task depends upon

Closed by  Alexander F. Rødseth (xyproto)
Monday, 21 May 2012, 22:16 GMT
Reason for closing:  No response
Additional comments about closing:  No response for a few days + works for me.
Comment by Alexander F. Rødseth (xyproto) - Saturday, 05 May 2012, 15:04 GMT
Thanks for reporting. While waiting for a new release, "midori-git" or "midori-gtk2-git" from AUR might work for you.
Comment by Alexander F. Rødseth (xyproto) - Tuesday, 15 May 2012, 11:04 GMT
I'm planning to add the patch to the midori package, while we are waiting for the next release.
Comment by Raphael Groner (k0Do) - Tuesday, 15 May 2012, 15:24 GMT
I'm using midori-git from AUR, version 0.4.5a-63-g678ef8a. It works quite well.
Comment by Alexander F. Rødseth (xyproto) - Wednesday, 16 May 2012, 20:25 GMT
I tried downloading a pdf. Since I had xpdf installed, xpdf just displayed the pdf. After uninstalling xpdf, evince and epdfview, the pdf downloaded just fine (before that, it was displayed).
When downloading a .zip, everything worked fine too. I haven't seen an empty GTK window yet.

Are there other steps that can be taken to reproduce?

Loading...