Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#29738 - [libreoffice] Installing LibreOffice via AIF causes LibreOffice's language to default to Afrikaans

Attached to Project: Arch Linux
Opened by LinuxMercedes (LinuxMercedes) - Friday, 04 May 2012, 05:59 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 20 May 2012, 12:02 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Dieter Plaetinck (Dieter_be)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Installing LibreOffice via AIF causes LibreOffice's language to default to Afrikaans instead of the language chosen for the system.

Additional info:
AIF version 2011.10.09-2
LibreOffice version 3.5.2-1

Steps to reproduce:
Install a new system via AIF
Add LibreOffice to the list of packages to install
Observe that LibreOffice is in Afrikaans on a system that is not Afrikaans at all.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 20 May 2012, 12:02 GMT
Reason for closing:  Won't fix
Additional comments about closing:  It's recommendes to install a base system and then add what you need. Then pacman will ask for the desired langpack.
Comment by Evangelos Foutras (foutrelis) - Friday, 04 May 2012, 07:25 GMT
That happens because all the libreoffice-{lang} packages provide libreoffice-langpack.
libreoffice-common depends on libreoffice-langpack, and thus the first language pack
gets installed.

pacman would normally ask you which language pack you want, but during installation
it's called with --noconfirm I think, so it just picks the first one.

A workaround might be to select the language pack you want during installation.

The fix now is to replace the Afrikaans language pack with the one you want:

# pacman -S libreoffice-en-US --asdeps
# pacman -R libreoffice-af
Comment by LinuxMercedes (LinuxMercedes) - Friday, 04 May 2012, 16:46 GMT
I've fixed it on my machine, but it doesn't seem that that's the way the default installer should work.
Comment by Evangelos Foutras (foutrelis) - Friday, 04 May 2012, 17:05 GMT
I have added Dieter (AIF developer) so he can have a look.

However, this is really an extreme edge case (most people will start
with a base system and boot into it to add non-core packages.) It's
also easily fixable. I wouldn't hold my breath for a fix.
Comment by Arno (ihad) - Saturday, 19 May 2012, 07:32 GMT
I had a similar problem. I installed arch via PXE/netboot recently, using 2012.04-2 (x86_64). I selected kde and xorg in the first stage of package selection and left everything else as default. Close to the end of install I got a selection about java-something and <Continue> appeared. On pressing enter I ended up in the main menu again, I think. Not sure any more. Same problem? Or a different bug? IMHO it's not really an edge case to install kde from aif. In the end everything worked as expected. When I installed the packages with the same selection again, it worked.
I couldn't tell if the install completed successfully the first time. So I guess it's just a cosmetic problem, but would be nice to let the user know that everything is OK.