Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29725 - [pdksh] package ships with a broken wrapper

Attached to Project: Arch Linux
Opened by Danijel Tasov (data) - Thursday, 03 May 2012, 06:33 GMT
Last edited by Eric Belanger (Snowman) - Monday, 10 September 2012, 22:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Aaron Griffin (phrakture)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

First of all, the warning should be printed to STDERR at least.
The wrapper should be fixed: usr_ksh.sh

---
#!/bin/sh

echo "WARNING: you should be calling ksh with /bin/ksh," >&2
echo "not with /usr/bin/ksh. Please execute chsh to fix" >&2
echo "this. Legacy /usr/bin/ksh support will go away!" >&2
echo "" >&2

exec /bin/ksh "$@"
---

>&2 at the echos and "$@" instead of $@ to fix arguments with whitespaces.

Alternatively, remove the skript now. It's badly behaved, because normally /usr/bin is found in front of /bin in $PATH. So just executing "ksh" leads to that warning.

Additional info:
* pdksh 5.2.14-6

Steps to reproduce:

$ cat test.ksh
for i in "$@"; do
echo "ARG: $i"
done
$ ksh test.ksh 'a b' 'c d'
WARNING: you should be calling ksh with /bin/ksh,
not with /usr/bin/ksh. Please execute chsh to fix
this. Legacy /usr/bin/ksh support will go away!

ARG: a
ARG: b
ARG: c
ARG: d
$ /bin/ksh test.ksh 'a b' 'c d'
ARG: a b
ARG: c d
This task depends upon

Closed by  Eric Belanger (Snowman)
Monday, 10 September 2012, 22:34 GMT
Reason for closing:  Won't fix
Additional comments about closing:  pdksh is now in AUR
Comment by Danijel Tasov (data) - Thursday, 03 May 2012, 06:53 GMT
Thought about it a bit more. If you decide to fix the script instead of removing it, use that one. It prints the warning only if STDERR is connected to a tty. That is less harmfull, it's still unexpected behavior, but at least it makes sure that stderr is not connected to some program that takes that stream as input and wants to do something with it (Creating, deleting files, or inserting that things into a database or whatever).
Comment by Alexander F Rødseth (xyproto) (trontonic) - Monday, 10 September 2012, 09:25 GMT
This package is an orphan. Assigned to the two last packagers (please move this package to [community] if there is no interest for it).
Comment by Eric Belanger (Snowman) - Monday, 10 September 2012, 18:04 GMT
Alexander: Is there a TU interested in it?
Comment by Alexander F Rødseth (xyproto) (trontonic) - Monday, 10 September 2012, 20:50 GMT
I think there is. If nobody else will, I will consider maintaining it. However, if it so happens that no developer and no TU is interested in maintaining it, perhaps it wouldn't be so wrong to move it all the way to unsupported.

Loading...