Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29713 - Firefox will not connect to some servers without IPV6 disabled

Attached to Project: Arch Linux
Opened by Karl (Arch_KP) - Wednesday, 02 May 2012, 19:16 GMT
Last edited by Evangelos Foutras (foutrelis) - Sunday, 06 May 2012, 07:29 GMT
Task Type General Gripe
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Firefox reports that it 'cannot connect to server', this happens for only a few servers. Links browser and firefox on windows (without the network.dns.disable.IPv6=TRUE) will connect without issue.
The url below is an example, that will not work on the freshly installed firefox 12.0-2 package on Arch 64. The url will work on Links text browser and on firefox under windows without any config modifications.
No modifications to the configs of the above are done before trying, after changing the setting for Arch firefox the url (or server) will work.

http://www.linuxquestions.org/questions/linux-newbie-8/change-colors-in-bash-background-and-text-696057/

I had this issue a bit before, but thought it might be related to my network setup at the time. Now my network setup is without issue.

Additional info:
* package version(s)
Firefox 12.0-2

* config and/or log files etc.
uncertain of how to dump the full firefox configuration file.

Steps to reproduce:
simply change network.dns.disable.IPv6=TRUE in about:config Firefox settings. (Nothing else was changed from default package, no settings changed before)
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Sunday, 06 May 2012, 07:29 GMT
Reason for closing:  Works for me
Additional comments about closing:  Closed at OP's request.
Comment by Karol Błażewicz (karol) - Wednesday, 02 May 2012, 19:52 GMT
On my 32-bit Arch the default value for network.dns.disableIPv6 is 'false' and the link works.
After toggling it to 'true', the link still works.
Comment by Jelle van der Waa (jelly) - Thursday, 03 May 2012, 18:32 GMT
Worksforme

Loading...