Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#29709 - [wicd-curses] crashes when trying to save network properties

Attached to Project: Arch Linux
Opened by halfie (halfie) - Wednesday, 02 May 2012, 15:04 GMT
Last edited by Isenmann Daniel (ise) - Sunday, 06 May 2012, 20:26 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Isenmann Daniel (ise)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No



wicd-curses crashes when trying to save network properties

DBus failure! This is most likely caused by the wicd daemon stopping while wicd-curses is running. Please restart the daemon, and then restart wicd-curses.
Traceback (most recent call last):
File "/usr/share/wicd/curses/", line 921, in call_update_ui
File "/usr/share/wicd/curses/", line 88, in wrapper
return func(*args, **kargs)
File "/usr/share/wicd/curses/", line 932, in update_ui
File "/usr/share/wicd/curses/", line 913, in handle_keys
File "/usr/share/wicd/curses/", line 481, in save_settin
self.set_net_prop("enctype", "None")
File "/usr/share/wicd/curses/", line 448, in set_net_pro
wireless.SetWirelessProperty(self.networkid, option, value)
File "/usr/lib/python2.7/site-packages/dbus/", line 145, in __ca
File "/usr/lib/python2.7/site-packages/dbus/", line 651, in cblocking
message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.TypeError: Traceb(most recent call last):
File "/usr/lib/python2.7/site-packages/dbus/", line 707, in _mes_cb
retval = candidate_method(self, *args, **keywords)
File "/usr/share/wicd/daemon/", line 1067, in SetWirelessProy
prop = misc.sanitize_config(prop)
File "/usr/lib/python2.7/site-packages/wicd/", line 433, in sanitiznfig
return s.translate(None, table)
TypeError: translate() takes exactly one argument (2 given)

Additional info:
* package version(s)
* config and/or log files etc.

Steps to reproduce:

1) Configure ("C") an network and then try to save it (F10).
This task depends upon

Closed by  Isenmann Daniel (ise)
Sunday, 06 May 2012, 20:26 GMT
Reason for closing:  Fixed
Additional comments about closing:  New package release -2. Don't forget to restart the daemon after update that the changes take effect.
Comment by stardogg champ (stardoggchamp) - Wednesday, 02 May 2012, 20:49 GMT
The following will hopefully fix the problem:

sudo rc.d stop wicd

prop = misc.sanitize_config(prop)
prop = misc.sanitize_config(str(prop))

sudo rc.d start wicd
Comment by pluto9 (pluto9) - Thursday, 03 May 2012, 01:36 GMT
I'm experiencing the same problem when I use wicd-gtk I can't save the properties and it shows the similar error messages. Stardoggchamp's method solves the problem.
Comment by Willie (bananabrain) - Thursday, 03 May 2012, 10:13 GMT doesn't pull any different dependencies.
A simple reversion back to fixes everything for me.
Comment by Isenmann Daniel (ise) - Thursday, 03 May 2012, 11:28 GMT
I have reported it upstream, looks like a problem upstream:
Comment by Willie (bananabrain) - Thursday, 03 May 2012, 17:44 GMT
Comment by james bos (jampola) - Friday, 04 May 2012, 15:44 GMT
stardoggchamp, doing that solved the issue for me.

Had the same problem here using both gtk and curses clients.

Comment by Christian Hesse (eworm) - Sunday, 06 May 2012, 04:59 GMT
I am suffering this as well. Here is the official upstream fix:

Do we wait for next release or can we push
Comment by pluto9 (pluto9) - Sunday, 06 May 2012, 06:20 GMT
I tried upstream fix eworm mentioned but it didn't solve the problem.
Comment by Christian Hesse (eworm) - Sunday, 06 May 2012, 07:26 GMT
Mh, it did fix it for me... Anybody else?
Comment by Isenmann Daniel (ise) - Sunday, 06 May 2012, 20:22 GMT
Patch does work for me, I will release a new package release...