Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29708 - [php] simplexml problems

Attached to Project: Arch Linux
Opened by Slavi Pantaleev (s.pantaleev) - Wednesday, 02 May 2012, 12:24 GMT
Last edited by Pierre Schmitz (Pierre) - Monday, 11 June 2012, 09:03 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Pierre Schmitz (Pierre)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Using PHP 5.4.1-2, I'm getting the same problem as the one described here - https://github.com/symfony/symfony/issues/3643
Same steps to reproduce.

https://bugs.php.net/bug.php?id=52858 - this looked similar and I can reproduce it on both 5.4.1 and 5.3.11.
The original problem is only seen on 5.4.1 though, so it's probably something else.

I took a look at the PKGBUILD for 5.3 and 5.4 and saw that `--enable-xml` was missing from the new one (most likely intentionally).
I tried rebuilding with it, but that didn't help.
This task depends upon

Closed by  Pierre Schmitz (Pierre)
Monday, 11 June 2012, 09:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in 3.1.10-3
Comment by Pierre Schmitz (Pierre) - Thursday, 03 May 2012, 11:49 GMT
This seems to be a related upstream bug report: https://github.com/symfony/symfony/issues/4185 Chances are this is not an Arch specific problem.
Comment by Pierre Schmitz (Pierre) - Saturday, 05 May 2012, 18:53 GMT
I tracked down a similar problem to the use of APC. Try if disabling the APC extension fixes the problem for you.
Comment by Slavi Pantaleev (s.pantaleev) - Saturday, 05 May 2012, 19:31 GMT
Yes, good catch - disabling the APC extension fixes the problem.
Comment by Pierre Schmitz (Pierre) - Saturday, 05 May 2012, 21:12 GMT
I filed an upstream bug report: https://bugs.php.net/bug.php?id=61956

Loading...