Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29694 - [linux] linux-3.3.4 i686 crashes while accessing files

Attached to Project: Arch Linux
Opened by ybsar (ybsar) - Tuesday, 01 May 2012, 15:08 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 02 May 2012, 17:48 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:
After upgrading my EeePC to linux-3.3.4-1-ARCH, the system randomly crashed, from time to time, while I was using it (that is not at boot time). It seems to crash more frequently when applications access many files. Sometime an Oops message is displayed, otherwise the system just hangs up without warning.

No more crash since I rolled it back to linux-3.3.3-1-ARCH.

Additional info:
Processor: i686 Intel(R) Atom(TM) CPU N270 @ 1.60GHz GenuineIntel.
Attached log file comes from "dmesg" just before a crash using "dd".

Steps to reproduce:
dd if=/dev/any_partition | strings | grep Oops
(then the system crashes within a few minutes/seconds)
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 02 May 2012, 17:48 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.3.4-2 & 3.0.30-2
Comment by Tobias Powalowski (tpowa) - Tuesday, 01 May 2012, 16:32 GMT
Yes I can somehow confirm this on one of my i686 machines too.
Comment by Dave Reisner (falconindy) - Tuesday, 01 May 2012, 17:09 GMT
Does disabling transparent hugepages help?

echo 'never' >/sys/kernel/mm/transparent_hugepage/enabled
Comment by Jochen Maes (Gcool) - Tuesday, 01 May 2012, 17:44 GMT
Experiencing the same issue on one of my machines as well (i686). Transparent hugepages was/is already disabled.
Comment by ybsar (ybsar) - Tuesday, 01 May 2012, 18:01 GMT
Transparent hugepage support is disabled by default (no such file or directory).
Comment by Jochen Maes (Gcool) - Tuesday, 01 May 2012, 19:45 GMT
Fairly daft of me to not try this earlier, but when I set transparent_hugepage to "always", the issue disappears in my case.
Comment by Michael Berg (jk799) - Tuesday, 01 May 2012, 23:22 GMT
This Bug also affects me, but just with the pae kernel from aur ( https://aur.archlinux.org/packages.php?ID=51326 ), not with the stock i686 kernel.
Comment by Tobias Powalowski (tpowa) - Wednesday, 02 May 2012, 07:19 GMT
This seems i686 only am I correct here?
My system is a pentium celeron.
Comment by Jochen Maes (Gcool) - Wednesday, 02 May 2012, 07:28 GMT
Only seeing the issue on my i686 install here as well (also a celeron). Haven't been able to replicate it on x86_64.
Comment by Anton Bobrov (baverman) - Wednesday, 02 May 2012, 08:01 GMT
Same here. i686 crash during high io.
Comment by Roberto Catini (robcat) - Wednesday, 02 May 2012, 08:59 GMT
Same here (i686, atom N270, 1GiB RAM): freeze after 20 minutes of normal usage; trying to unzip a large file (100% cpu load), the freeze is guaranteed in 20 seconds.
Booting with transparent_hugepage=always doesn't seem to help.
With the previous linux 3.3.3 no similar crashes.
Comment by Outmatch (hrimfaxi) - Wednesday, 02 May 2012, 09:00 GMT
Same here. Hangs up during running firefox etc. Had to downgrade to 3.3.3.
Comment by Bill Allen (wallenpb) - Wednesday, 02 May 2012, 15:12 GMT
Saw same issue here after linux-3.3.4-1 kernel upgrade from pacman. Rolled back to linux-3.3.3-1 and problem went away. I would suggest linux-3.3.4-1 be pulled from the updates until resolved since this causes crashes.
Comment by Tobias Powalowski (tpowa) - Wednesday, 02 May 2012, 15:39 GMT
fixed kernel package will appear in 2 hours in repos

Loading...