Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#29683 - [networkmanager] nmcli: Error: Can't obtain connections: settings service is not running.

Attached to Project: Arch Linux
Opened by carbolymer (carbolymer) - Monday, 30 April 2012, 22:37 GMT
Last edited by Ionut Biru (wonder) - Saturday, 01 September 2012, 09:24 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Ionut Biru (wonder)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 13
Private No


While trying to run:
$ nmcli con

The effect is:
Error: Can't obtain connections: settings service is not running.

Which makes impossible to manage connections through command line.

Additional info:
* package version(s):
dbus 1.4.20-1

* config and/or log files etc.
No log files are being created.

Steps to reproduce:
Run command in terminal
$ nmcli con
This task depends upon

Closed by  Ionut Biru (wonder)
Saturday, 01 September 2012, 09:24 GMT
Reason for closing:  Fixed
Additional comments about closing:  0.9.6
Comment by Alex Sayers (asayers) - Wednesday, 02 May 2012, 03:46 GMT
I'm getting this too.

It's reported on the Ubuntu launchpad bugtracker [1] that this issue was resolved upstream on 4/5/2012 by this commit [2].

Comment by samae (samae) - Wednesday, 16 May 2012, 20:01 GMT
Same here, when will the fix be propagated to Arch's pacman ?
Comment by Ionut Biru (wonder) - Wednesday, 16 May 2012, 20:35 GMT
can you confirm that is fixing your problem if you apply the fix from [2] ?
Comment by samae (samae) - Thursday, 17 May 2012, 18:48 GMT
I can't since I wasn't patient enough.
I solved my problem by installing AUR's networkmanager-git. The issue was resolved upstream for sure, since it works properly now.
I'd still like an updated version in the repo instead of keeping on with this git build.
Comment by Ionut Biru (wonder) - Thursday, 17 May 2012, 18:58 GMT
i'm waiting your answer.
Comment by samae (samae) - Friday, 18 May 2012, 19:15 GMT
That I did, yes bug is fixed. Now please update networkmanager in the repo.
Comment by cunnilinux (cunnilinux) - Thursday, 28 June 2012, 04:53 GMT
got this effect today on the fresh install (core system + mc + networkmanager).

dbus-core 1.6.0-4

(still have not tried networkmanager-git).
Comment by Jochen Keil (jrk) - Friday, 06 July 2012, 20:42 GMT

I applied the patch from [1] to this nm package. Nmcli now works as expected.

Comment by Jelle van der Waa (jelly) - Saturday, 28 July 2012, 13:54 GMT
There is going to be a new release soon since there is an RC2 out, so hopefully it will ship the fix.