Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29673 - Hibernating kills root partition

Attached to Project: Arch Linux
Opened by Rasmus Steinke (rasi) - Monday, 30 April 2012, 13:56 GMT
Last edited by Tobias Powalowski (tpowa) - Thursday, 03 May 2012, 11:20 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture i686
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description: After waking up from hibernate, i see lots of "illegal pblock on /dev/sda3" (which is my / partition)
trying to mount shows "no filesystem on /dev/sda3" and cfdisk confirms this.


Additional info:

* package version(s):
kernel 3.3.4-1
pm-utils 1.4.1-4


* config and/or log files etc.
No way to provide any configs, since the filesystem is gone for good.
Hardware: Samsung N220 Netbook


Steps to reproduce:
Here is what i did: Installed arch linux with netinstall, installed, X, xfce, pm-utils, networkmanager and broadcom-wl for my bcm4313 card.
edited syslinux.cfg (resume=/dev/sda2) - this is of course my swap partition
added the resume hook to mkinitcpio.conf and rebuilt initramfs.
Rebooted and logged into X.
triggered a hibernate through xfce's panel item.
After waking up (which worked btw) I wasnt able to do anything. switching to tty1 showed those illegal pblock errors.
Root partition is gone for good, no more filesystem on it.

The first time this happened was on a setup that worked for at least a year (including hibernation) Last time i succesfully hibernated was a few days back.
The 2nd time was a clean setup from scratch.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Thursday, 03 May 2012, 11:20 GMT
Reason for closing:  Fixed
Comment by Krishnan (kgas) - Monday, 30 April 2012, 16:59 GMT
I can confirm this and attached part of everything.log. gparted says /dev/sda4 partition type is unknown and all the 12 GB is now free.
Comment by Matt (terra-byte) - Tuesday, 01 May 2012, 14:17 GMT
This also happens to me. Most of the time, you can restore the corrupted partition by running fsck on it. I tried using a kernel patched with TuxOnIce, but the problem still remains. The problem started yesterday, right after I ran pacman -Syu, although the updates were mainly the xfce-4.10 packages. I use a custom linux-ck kernel version 3.3.4, which worked fine until now.

EDIT: I just reinstalled Arch, 64-bit this time instead of 32-bit, and everything is fine now. It seems this only affects the 32-bit version.
Comment by Stefan (cryptkeeper) - Tuesday, 01 May 2012, 20:54 GMT
This happened to me, too. I did 'yaourt -Syu' yesterday and also rebooted successfully afterwards. Then I put my computer (MacBook4 with OSX/Arch dualboot) to hibernation. When I woke it up, it did so (i.e. Gnome3 appeared), but it was frozen. I pressed the power button, and that was it, only Grub Shell appeared on trying to run Arch, and the filesystem was not recognized anymore by anything (Grub Shell, SystemRescueCd, SuperGrub2Disk). rEFIt and MacOSX always worked fine, only the Arch partition was killed.
Comment by Christian Neukirchen (chneukirchen) - Wednesday, 02 May 2012, 14:15 GMT
Can confirm on an IBM x40.
Comment by Otto Allmendinger (OttoA) - Wednesday, 02 May 2012, 20:37 GMT
shouldn't 3.3.4 be pulled from [core]?
Comment by Daniel (weirddan455) - Thursday, 03 May 2012, 04:21 GMT
There's an update from 3.3.4-1 to 3.3.4-2 in [core] now. Does this fix this bug?
Comment by Greg Darke (skunktrader) - Thursday, 03 May 2012, 04:25 GMT
Same problem using i686 3.3.4-1. Hibernate/thaw has been working flawlessly for more than a year. Root partition type set to unknown. Was able to repair the partition by fsck'ing /dev/sda1 and rebooted successfully.
Comment by Evangelos Foutras (foutrelis) - Thursday, 03 May 2012, 04:29 GMT
It would be great if someone who has experienced this issue gave 3.3.4-2 a try and reported back. :p
Comment by Otto Allmendinger (OttoA) - Thursday, 03 May 2012, 10:19 GMT
the changelog for 3.3.4-2 says it is a rebuild with different binutils, so it is doubtful that this will have any effect on the bug

https://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/linux&id=cbdafa53a8f95e009a2ff49dfa6e1fcd16ed3b5d

Meanwhile 3.3.4-1 is still in [core] and endangering peoples data. I don't get it - why isn't this package being pulled?
Comment by Evangelos Foutras (foutrelis) - Thursday, 03 May 2012, 10:40 GMT
[core] contains 3.3.4-2, not 3.3.4-1.

3.3.4-2 solves the freezes we were seeing with 3.3.4-1, and it likely fixes this issue as well.
Comment by Evangelos Foutras (foutrelis) - Thursday, 03 May 2012, 11:15 GMT
Just tested both kernels in a virtual machine. 3.3.4-1 can't resume from hibernation (it panics) but 3.3.4-2 works fine.

Loading...