Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#29629 - [evolution] 3.4.1-1: black on black / slow URL resolution / no downgrade possible

Attached to Project: Arch Linux
Opened by Stefan Förster (HotblackDesiato) - Thursday, 26 April 2012, 19:18 GMT
Last edited by Allan McRae (Allan) - Friday, 16 November 2012, 22:46 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



Recently, I upgraded evolution on three Arch Linux installations (both i686 ands x86_64) from 3.2.x to 3.4.1-1.

I am very unhappy with this new version. I tried to downgrade to the 3.2 version on one installation, but this is not possible. The old version then starts with a grey window with almost no contents (i.e. no list of e-mails etc.). I had to upgrade it again.

Anomalies in the new 3.4.1-1 version:

1) Very dark background colour: Evolution now uses a very dark background colour, extremely dark grey. For instance, in the list of e-mails, the highlighted e-mail is displayed with black font and very dark grey background. The text is almost not readable. When you open an arbitrary e-mail, the heading of the e-mail is displayed black on black, i.e. you can't read anything in the mail header. This happens in all three Arch Linux installations.

2) URL resolution is extremely slow. Some links do not seem to open in the systems standard browser, at least not within 3-5 minutes. This happens in all three Arch Linux installations.

3) Some settings from the old 3.2 version have been cleared and reset to standard settings, e.g. the standard character setting to be used in e-mails or that the e-mail format is HTML. I had to enter my preferred settings again. Also, this behaviour happened in all three installations.

Steps to reproduce: upgrade evolution to version 3.4.1-1
This task depends upon

Closed by  Allan McRae (Allan)
Friday, 16 November 2012, 22:46 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed-ish... Upstream issue
Comment by Ionut Biru (wonder) - Thursday, 26 April 2012, 20:39 GMT
there is nothing we can do here. please redirect your feedback to
Comment by Stefan Förster (HotblackDesiato) - Sunday, 29 April 2012, 10:30 GMT
I filed the following bug reports for the "black baground bug":
Comment by Stefan Förster (HotblackDesiato) - Sunday, 29 April 2012, 16:23 GMT
I found a workaround: downgrade the package "gtk3" from 3.4.1 to 3.2.3.

The Gnome team has marked my bug report as "duplicate" of another bug report, that is marked as "resolved". I doubt that this issue is really resolved...
Comment by Henry78 (Henry78) - Monday, 07 May 2012, 12:19 GMT
The 'black' issue was solved here with the latest 3.4.1 update (or 3.4.1-1?).
Comment by Stefan Förster (HotblackDesiato) - Wednesday, 09 May 2012, 18:45 GMT
I just gave 3.4.2-2 a try. The "black on black" bug still persists (on my IBM ThinkPad T23 with fluxbox - I haven't tried it on the other two machines).
Comment by Ionut Biru (wonder) - Wednesday, 09 May 2012, 18:58 GMT
do you have gtkhtml4 4.4.1-2 ?
Comment by Stefan Förster (HotblackDesiato) - Thursday, 10 May 2012, 16:48 GMT
Yes, gtkhtml4 4.4.1-2 is installed. Here is the yaourt output:

yaourt gtkhtml
1 extra/gtkhtml 3.32.2-3 [installed]
A lightweight HTML renderer/editor widget for GTK2
2 extra/gtkhtml-sharp 2.26.0-8 [installed]
Mono bindings for gtkhtml
3 extra/gtkhtml4 4.4.1-2 [installed]
A lightweight HTML renderer/editor widget for GTK3
4 extra/libgtkhtml 2.11.1-4
An HTML library for GTK
5 extra/python2-gtkhtml2 2.25.3-12
Python bindings for the gtkhtml2
6 aur/claws-mail-gtkhtml2viewer 0.30-2 (3)
HTML renderer plugin for Claws Mail.
7 aur/lib32-libgtkhtml 2.11.1-8 (2)
A HTML library for GTK (32-bit)
8 aur/ruby-gtkhtml2 0.16.0-1 (Out of Date) (0)
Ruby gtkhtml2 bindings
Comment by Jan de Groot (JGC) - Sunday, 19 August 2012, 16:56 GMT
What's the status?
Comment by Stefan Förster (HotblackDesiato) - Tuesday, 21 August 2012, 12:42 GMT
I use the current versions of evolution (3.4.4-1) and gtk3 (3.4.4-1).

As regards 1): Since the update of gtk3 to this version, the "black on black" bug is almost gone. It still persists if you mark a text in an e-mail. It gets rendered black on black (on both notebooks under Arch Linux, one with fluxbox and the other with KDE4, and on one desktop computer with KDE4). Though the header of the e-mail etc., which I had initially reported to be displayed "black on black", is now displayed in the correct colours.

2) URL resolution time is now back to normal, I'd say, although it is still a bit slow.

3) Settings topic: I can't repro this, unless I'd delete all my settings, reinstall an old version of evolution, set all my preferences and update again. I don't want to do this.

Comment by Greg (dolby) - Monday, 15 October 2012, 10:09 GMT Comment by Stefan Förster (HotblackDesiato) - Saturday, 20 October 2012, 18:47 GMT
As per my last comment, the "black on black" bevaviour is almost gone. It is still there, if one marks a text in an e-mail. The marked text is "black on black".