Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29627 - [mythtv] recording fails

Attached to Project: Community Packages
Opened by Johan R (cleanrock) - Thursday, 26 April 2012, 16:02 GMT
Last edited by Jonathan Conder (PirateJonno) - Friday, 06 July 2012, 14:34 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jonathan Conder (PirateJonno)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

After the 0.25 upgrade recording have started to fail for me on my PVR-350, i see this in the log :
2012-04-24 22:00:04.209845 E [3077/18539] DeviceReadBuffer DeviceReadBuffer.cpp:513 (Poll) - DevRdB(/dev/video0): Poll giving up 2

I suspect this is corrected by the following commit on fixes/0.25 branch:
https://github.com/MythTV/mythtv/commit/f81f712537b63502814d1f274c7da14196cedd8c
I found the following tickets (which led me to the commit above) after doing some searching:
http://code.mythtv.org/trac/ticket/10519
http://code.mythtv.org/trac/ticket/9830

Can we please switch to fixes/0.25 for mythtv ?
My mythtv is pretty unusable atm, at some point recording fails and after that all recording will fail until i restart mythtv after reloading ivtv.


Additional info:
mythtv 1:0.25-3
This task depends upon

Closed by  Jonathan Conder (PirateJonno)
Friday, 06 July 2012, 14:34 GMT
Reason for closing:  Fixed
Comment by Jonathan Conder (PirateJonno) - Tuesday, 01 May 2012, 12:46 GMT
I'll have a think about this. Up until now I've preferred using the stable releases as something tends to go wrong between every new version, so the fewer updates the less time needs to be spent making sure everything still works. However if even these aren't working properly then maybe it would make sense to use the fixes branch. Only thing is I'm not sure when I should be updating (e.g. monthly, only when someone reports a bug, etc.). It seems like this is what the other distros are doing so I guess it makes sense.
Comment by Jonathan Conder (PirateJonno) - Friday, 18 May 2012, 00:00 GMT
I think I'll go ahead and do this. At the same time I'm going to make the backend run as the mythtv user by default so I'll need some time to figure out how to do that without breaking existing setups
Comment by Johan R (cleanrock) - Friday, 29 June 2012, 16:57 GMT
Update mythtv to 0.25.1 and you can close this :).
Joke aside, i did not experience this problem that much since this bug report and have then moved to a DVB-T2 usb adaptor, hopefully you will get the time to upgrade to 0.25.1.
Comment by Jonathan Conder (PirateJonno) - Saturday, 30 June 2012, 02:50 GMT
I still plan to switch to fixes, as it will avoid problems like this in future. Was waiting for the x264 rebuild to go through, but that seems to be taking longer than I anticipated. Will try to update anyway, although I may not be able to test as I've already switched to the new x264. We'll see.
Comment by Jonathan Conder (PirateJonno) - Saturday, 30 June 2012, 07:50 GMT
never mind, too much effort to make the switch - at this rate the mythtv devs are actually faster than I have been lately... hopefully that will change in future but for now it just makes sense to stick with 0.25.1
Comment by Jonathan Conder (PirateJonno) - Thursday, 05 July 2012, 11:13 GMT
Can you confirm whether this is fixed?
Comment by Johan R (cleanrock) - Thursday, 05 July 2012, 15:06 GMT
No, ditched my PVR-350.
I think we can close this with good conscience, i doubt it is not fixed.

Loading...