Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#29605 - File systems not mounted on boot

Attached to Project: Arch Linux
Opened by Andrej Podzimek (andrej) - Tuesday, 24 April 2012, 21:08 GMT
Last edited by Dave Reisner (falconindy) - Tuesday, 24 April 2012, 21:30 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No



After rebooting my server system after today's pacman -Syu, file systems from /etc/fstab didn't get mounted. (Tried multiple times, but still the same result.) The root filesystem was remounted rw as usual.

Other symptoms of this problem:
* /etc/mtab is obviously outdated after each reboot, listing the mounts that existed prior to the reboot. But the root filesystem is remounted rw normally, so there's no reason why /etc/mtab should remain "frozen".
* /proc/mounts shows that only the root (/) filesystem is mounted, whereas /home, /var and /var/log are not.
* Mounting all the file systems manually works perfectly fine -- no error messages, no issues, standard mout messages in dmesg.

Additional info:
* I use a *vanilla* kernel (3.2.16) with a standard mkinitcpio-generated image.
* The system has worked with exactly the same /etc/fstab for >1 year and it always booted just fine.
* All the file systems are on software RAID + LVM. (Could this be a weird udev issue...?)

* package version(s)
filesystem 2012.2-4
initscripts 2012.03.2-1
udev 182-1
mdadm 3.2.3-1
lvm2 2.02.95-1
mkinitcpio 0.8.7-2

* config and/or log files etc.
Since /var/log was not mounted, none of the daemons started properly and I don't have any meaningful logs. (Can't reboot the server all the time and experiment, unfortunately...)
There was nothing suspicious in dmesg, no failures at all.

/etc/fstab and /etc/mdadm.conf are attached. (It's good to use :set ts=4 or the like when reading fstab.)

Steps to reproduce:
Dunno. This might be related to the specific configuration of this machine. The attachments contain the configuration that might reproduce the problem.
This task depends upon

Closed by  Dave Reisner (falconindy)
Tuesday, 24 April 2012, 21:30 GMT
Reason for closing:  Deferred
Comment by Dave Reisner (falconindy) - Tuesday, 24 April 2012, 21:18 GMT
There's no reason /etc/mtab should be a real file. We only support it as a symlink to /proc/self/mounts. This is probably related.
Comment by Andrej Podzimek (andrej) - Tuesday, 24 April 2012, 21:28 GMT
OK, I see! It really *is* a symlink to /proc/self/mounts on all my ArchLinux systems but the server... So this may have been the reason why this issue occurred.

Unfortunately, I cannot try to reboot the server any time soon. I suggest that we close this "bug" report for now and I'll reqest re-opening in case if the problem occurs again with the correct symlink.

Thank you for your advice.
Comment by Dave Reisner (falconindy) - Tuesday, 24 April 2012, 21:30 GMT
Sure, feel free to reopen if this is still an issue.