Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29591 - [gnome-games] Glines segfault

Attached to Project: Arch Linux
Opened by Stéphane Marguet (Stemp) - Tuesday, 24 April 2012, 08:11 GMT
Last edited by Evangelos Foutras (foutrelis) - Sunday, 28 April 2013, 14:00 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

Glines Segmentation fault

Additional info:

* package version(s) : 3.4.1-1

$ dmesg | grep -i glines
[ 1194.864955] glines[3224]: segfault at 17 ip b6e0556a sp bfc84830 error 4 in libcairo.so.2.11000.2[b6dc9000+c9000]

$ gdb glines
GNU gdb (GDB) 7.4
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/glines...done.
(gdb) set pagination 0
(gdb) run
Starting program: /usr/bin/glines
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/libthread_db.so.1".
[New Thread 0xb6484b40 (LWP 4175)]
[New Thread 0xb5affb40 (LWP 4176)]

Program received signal SIGSEGV, Segmentation fault.
0xb6e7156a in cairo_pattern_create_for_surface () from /usr/lib/libcairo.so.2
(gdb) bt
#0 0xb6e7156a in cairo_pattern_create_for_surface () from /usr/lib/libcairo.so.2
#1 0x0805079c in draw_preview () at glines.c:445
#2 0x08050ab1 in preview_configure_cb (widget=0x95c2808, event=0x9891420) at glines.c:1438
#3 0xb73fbe72 in ?? () from /usr/lib/libgtk-3.so.0
#4 0xb7008606 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#5 0xb701a0f5 in ?? () from /usr/lib/libgobject-2.0.so.0
#6 0xb7022011 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#7 0xb7022453 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#8 0xb754397b in ?? () from /usr/lib/libgtk-3.so.0
#9 0xb737d4d9 in ?? () from /usr/lib/libgtk-3.so.0
#10 0xb700b455 in g_cclosure_marshal_VOID__BOXEDv () from /usr/lib/libgobject-2.0.so.0
#11 0xb7006f57 in ?? () from /usr/lib/libgobject-2.0.so.0
#12 0xb70087ed in ?? () from /usr/lib/libgobject-2.0.so.0
#13 0xb70219f9 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#14 0xb7022453 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#15 0xb7554086 in gtk_widget_size_allocate () from /usr/lib/libgtk-3.so.0
#16 0xb731781d in ?? () from /usr/lib/libgtk-3.so.0
#17 0xb700b455 in g_cclosure_marshal_VOID__BOXEDv () from /usr/lib/libgobject-2.0.so.0
#18 0xb7006f57 in ?? () from /usr/lib/libgobject-2.0.so.0
#19 0xb70087ed in ?? () from /usr/lib/libgobject-2.0.so.0
#20 0xb70219f9 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#21 0xb7022453 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#22 0xb7554086 in gtk_widget_size_allocate () from /usr/lib/libgtk-3.so.0
#23 0x080547ec in games_grid_frame_size_allocate (widget=0x9590aa0, allocation=0xbf844960) at games-gridframe.c:200
#24 0xb700b455 in g_cclosure_marshal_VOID__BOXEDv () from /usr/lib/libgobject-2.0.so.0
#25 0xb7006f57 in ?? () from /usr/lib/libgobject-2.0.so.0
#26 0xb70087ed in ?? () from /usr/lib/libgobject-2.0.so.0
#27 0xb70219f9 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#28 0xb7022453 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#29 0xb7554086 in gtk_widget_size_allocate () from /usr/lib/libgtk-3.so.0
#30 0xb731781d in ?? () from /usr/lib/libgtk-3.so.0
#31 0xb700b455 in g_cclosure_marshal_VOID__BOXEDv () from /usr/lib/libgobject-2.0.so.0
#32 0xb7006f57 in ?? () from /usr/lib/libgobject-2.0.so.0
#33 0xb70087ed in ?? () from /usr/lib/libgobject-2.0.so.0
#34 0xb70219f9 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#35 0xb7022453 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#36 0xb7554086 in gtk_widget_size_allocate () from /usr/lib/libgtk-3.so.0
#37 0xb731781d in ?? () from /usr/lib/libgtk-3.so.0
#38 0xb700b455 in g_cclosure_marshal_VOID__BOXEDv () from /usr/lib/libgobject-2.0.so.0
#39 0xb7006f57 in ?? () from /usr/lib/libgobject-2.0.so.0
#40 0xb70087ed in ?? () from /usr/lib/libgobject-2.0.so.0
#41 0xb70219f9 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#42 0xb7022453 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#43 0xb7554086 in gtk_widget_size_allocate () from /usr/lib/libgtk-3.so.0
#44 0xb755f699 in ?? () from /usr/lib/libgtk-3.so.0
#45 0xb700b455 in g_cclosure_marshal_VOID__BOXEDv () from /usr/lib/libgobject-2.0.so.0
#46 0xb7006f57 in ?? () from /usr/lib/libgobject-2.0.so.0
#47 0xb70088b1 in ?? () from /usr/lib/libgobject-2.0.so.0
#48 0xb70219f9 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#49 0xb7022453 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#50 0xb7554086 in gtk_widget_size_allocate () from /usr/lib/libgtk-3.so.0
#51 0xb755b2cb in ?? () from /usr/lib/libgtk-3.so.0
#52 0xb700a36f in g_cclosure_marshal_VOID__VOID () from /usr/lib/libgobject-2.0.so.0
#53 0xb700749d in ?? () from /usr/lib/libgobject-2.0.so.0
#54 0xb7008606 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#55 0xb7019aab in ?? () from /usr/lib/libgobject-2.0.so.0
#56 0xb70222d6 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#57 0xb7022453 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#58 0xb754e844 in gtk_widget_show () from /usr/lib/libgtk-3.so.0
#59 0xb7363952 in ?? () from /usr/lib/libgtk-3.so.0
#60 0xb754cf2a in gtk_widget_show_all () from /usr/lib/libgtk-3.so.0
#61 0x080521e7 in main (argc=1, argv=0xbf845cf4) at glines.c:1611
(gdb)

Steps to reproduce:
Start glines (Five or More)
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Sunday, 28 April 2013, 14:00 GMT
Reason for closing:  Fixed
Additional comments about closing:  five-or-more 3.8.1-1
Comment by Jelle van der Waa (jelly) - Tuesday, 24 April 2012, 18:33 GMT
Wonder probably would love it if you'd make a bugreport upstream
Comment by Jan de Groot (JGC) - Wednesday, 25 April 2012, 07:46 GMT
I can't reproduce this crasher, and it looks like a crash in cairo. Either an invalid call to a cairo function, or something bad inside cairo. What version of cairo do you use?
Comment by Stéphane Marguet (Stemp) - Wednesday, 25 April 2012, 08:02 GMT
Cairo 1.10.2-3 and now I'm using 1.12.0-4 from Testing with the same result :/
Comment by Hb (Hbb) - Friday, 04 May 2012, 06:04 GMT
In Ubuntu 12.04:
kernel: [42437.110615] glines[12333]: segfault at 17 ip 00af819a sp bfef1190 error 4 in libcairo.so.2.11000.2[abc000+c7000]
Comment by Hb (Hbb) - Sunday, 03 June 2012, 07:45 GMT
Comment by György Balló (City-busz) - Sunday, 19 August 2012, 14:57 GMT
The patch solves the problem for me. It was malformed, so I attached a correct one.

Please apply this patch.

(Upstream bug report: https://bugzilla.gnome.org/show_bug.cgi?id=675628 )
Comment by György Balló (City-busz) - Tuesday, 06 November 2012, 22:11 GMT
It still happens with gnome-games 3.6.1-1.

Here is a more simpler patch that solves the problem also:
https://bugzilla.gnome.org/show_bug.cgi?id=675628#c9
Comment by György Balló (City-busz) - Saturday, 27 April 2013, 22:30 GMT
It has been fixed in five-or-more 3.7.90.

EDIT: I mixed five-or-more and four-in-a-row. The fixed package name is five-or-more.

Loading...