Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#29524 - [sox] play does not work anymore.

Attached to Project: Arch Linux
Opened by Mikolaj Romel (wassup) - Wednesday, 18 April 2012, 14:38 GMT
Last edited by Eric Belanger (Snowman) - Sunday, 03 June 2012, 04:03 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


After upgrading sox from version 14.3.2-6 to 14.4.0-1 'play' command stopped working. The error message is rather cryptic:

$ play /usr/share/sounds/freedesktop/stereo/complete.oga
play FAIL formats: can't open output file `default': can not open audio device: Connection refused

I believe it might correlate to 'play' trying to use pulseaudio, which I do not use - I use plain alsa.

Additional info:
* version affected - sox 14.4.0-1

Steps to reproduce:
Play any audio file using play + plain alsa.
This task depends upon

Closed by  Eric Belanger (Snowman)
Sunday, 03 June 2012, 04:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  sox-14.4.0-2
Comment by Eric Belanger (Snowman) - Wednesday, 18 April 2012, 16:17 GMT
There doesn't seem to be any options to make alsa the default audio device at build time and there's no config file. You'll need to use the command line option:
$ sox infile -t alsa
or a wrapper script.
Comment by Havona (havona) - Wednesday, 18 April 2012, 16:42 GMT Comment by Mikolaj Romel (wassup) - Wednesday, 18 April 2012, 22:39 GMT
@Havona: Indeed, your fix works like a charm - thanks. I guess, not it is up to the developers to take care of it if they wish to do so.
Comment by Karol Błażewicz (karol) - Thursday, 19 April 2012, 23:42 GMT
sox 14.4.0-1 on my 32-bit Arch works fine.
I'm not using 'export AUDIODRIVER=alsa' and the only PA references I can find on my system are /usr/lib/sox/libsox_fmt_pulseaudio.a and /usr/lib/sox/
Comment by tim (sudokode) - Tuesday, 24 April 2012, 09:19 GMT
You can do a rough fix for this without any extra args or a wrapper. Jump into /usr/lib/sox, back up the two pulseaudio files (or remove them), and recreate them as symlinks to the alsa files. Works fine here, still a shitty fix.

Looks like arch isn't alone either: