Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29523 - [gnome-applets] blocks cpupower package

Attached to Project: Arch Linux
Opened by Ivan Lyapunov (dront78) - Wednesday, 18 April 2012, 11:29 GMT
Last edited by Evangelos Foutras (foutrelis) - Sunday, 19 August 2012, 04:24 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:
Unable to install cpupower beacuse it conflicts with cpufrequtils package installed due to gnome-applets 3.2.1

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
pacman -S gnome-applets
pacman -S cpupower
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Sunday, 19 August 2012, 04:24 GMT
Reason for closing:  Fixed
Additional comments about closing:  gnome-applets 3.4.1-2
Comment by Peter Weber (hoschi) - Sunday, 20 May 2012, 11:44 GMT
We have discussed this last year but it was decided to do nothing. The situation now has changed in some way:
Gnome seems not to maintain gnome-applets. But it is still a dependecy of the Gnome in fallback-mode. I suggest to remove cpufrequtils from the dependencies of gnome-applets and make it an optional dependency.

Rationale:
Only a small minority of users can access the applets, because only available in fallback-mode available. If someone uses the fallback-mode* and also want to use the cpu-applet it is still possible to install old cpufrequtils manually. All others would be better served with cpupower.

*Presumably I'm afraid power-management of the CPU won't help much in this cases. Because a missing or low-quality graphics driver will mess up entire power-management anyway.
Comment by Peter Weber (hoschi) - Saturday, 18 August 2012, 11:26 GMT
Thanks to "heftig" :-)
Fixed in stable! pacman will not remove or replace cpufrequtils by itself, if you want to this:

1. pacman -Syu
2. pacman -Qdt
3. if cpufrequtils is listed
pacman -Rns cpufrequtils
4. pacman -S cpupower (use it, e.g. "cpupower -c all frequency-info" or "cpupower frequency-set -g [performance, ondemand, powersave...]")

Loading...