Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#29508 - [linux] cdc-acm avrisp programmer doesn't bind to ttyACMx anymore

Attached to Project: Arch Linux
Opened by Manfred Miederer (LessWire) - Tuesday, 17 April 2012, 18:12 GMT
Last edited by Tobias Powalowski (tpowa) - Saturday, 28 April 2012, 06:06 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

For about 2 years i plugged the AVRISP MKII programmer to USB, cdc-acm module was loaded and /dev/ttyACMx has been created.

Since nearly 3 weeks this doesn't work anymore.

In my opinion it hasn't to do with the latest 3.3.x kernels, i tried 3.2.13 having the same problem. I also tried another brandnew programmer without success.
Other usb acm devices work well.

"udevadmin monitor --property" shows after plugging in the AVRISP:

[code]
UDEV [10988.989893] add /devices/pci0000:00/0000:00:1d.2/usb7/7-1 (usb)
ACTION=add
BUSNUM=007
DEVICE=/proc/bus/usb/007/004
DEVNAME=/dev/bus/usb/007/004
DEVNUM=004
DEVPATH=/devices/pci0000:00/0000:00:1d.2/usb7/7-1
DEVTYPE=usb_device
ID_BUS=usb
ID_MODEL=AVRISP_mkII
ID_MODEL_ENC=AVRISP\x20mkII
ID_MODEL_ID=2104
ID_REVISION=0200
ID_SERIAL=ATMEL_AVRISP_mkII_000200066501
ID_SERIAL_SHORT=000200066501
ID_USB_INTERFACES=:ff0000:
ID_VENDOR=ATMEL
ID_VENDOR_ENC=ATMEL
ID_VENDOR_ID=03eb
MAJOR=189
MINOR=771
PRODUCT=3eb/2104/200
SEQNUM=1635
SUBSYSTEM=usb
TYPE=255/0/0
USEC_INITIALIZED=10988989782

UDEV [10988.990538] add /devices/pci0000:00/0000:00:1d.2/usb7/7-1/7-1:1.0 (usb)
ACTION=add
DEVICE=/proc/bus/usb/007/004
DEVPATH=/devices/pci0000:00/0000:00:1d.2/usb7/7-1/7-1:1.0
DEVTYPE=usb_interface
INTERFACE=255/0/0
MODALIAS=usb:v03EBp2104d0200dcFFdsc00dp00icFFisc00ip00
PRODUCT=3eb/2104/200
SEQNUM=1636
SUBSYSTEM=usb
TYPE=255/0/0
USEC_INITIALIZED=10988990228
[/code]

- this MODALIAS doesn't match the aliases of the cdc-acm module (shown by modinfo)
- TYPE=255/0/0 / INTERFACE=255/0/0 - useful values??

Even though this had worked for years.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Saturday, 28 April 2012, 06:06 GMT
Reason for closing:  Not a bug
Comment by Manfred Miederer (LessWire) - Friday, 27 April 2012, 23:33 GMT
I've been confused because in the Arduino IDE it seemed like I worked such a long time with "ttyACMx" (cdc-acm module was loaded).

My latest experience is now that the avrisp is NOT an ACM device, you have to use "libusb" and "libusb-compat". Avrdude needs in addition the param "-Pusb" or you change "/dev/tty...." to "usb" in avrdude.conf file. "libusb" doesn't create a "/dev/tty...." node, it works with the kernels "/proc/bus/usb/....".

This is a way to get avrisp working fine (again).

Sorry for my inconvenience - the thread could be closed now.

Loading...